summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
commitd02bb02f7d833ad371c53c346b6cb77f01377cf4 (patch)
tree9506f04a7fde2f3b264ba1d2a9012085e1f72b72 /gnu/packages/fontutils.scm
parentfb3ff265cd8c6b4c6160f94240dc8932097e637b (diff)
parentacce0a474c1493ab18912bc46285248e4ccb0314 (diff)
downloadguix-patches-d02bb02f7d833ad371c53c346b6cb77f01377cf4.tar
guix-patches-d02bb02f7d833ad371c53c346b6cb77f01377cf4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 2ea4ff049e..2ff42945d7 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -194,6 +195,58 @@ TTF (TrueType/OpenType Font) files.")
(license license:bsd-2)
(home-page "https://github.com/wget/ttf2eot")))
+(define-public ttf2pt1
+ (package
+ (name "ttf2pt1")
+ (version "3.4.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ttf2pt1/ttf2pt1/"
+ version "/ttf2pt1-" version ".tgz"))
+ (sha256
+ (base32
+ "1l718n4k4widx49xz7qrj4mybzb8q67kp2jw7f47604ips4654mf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove trailing backslashes in the sed expression of the
+ ;; 'install' rule since sed would otherwise fail.
+ (substitute* "Makefile"
+ (("\\|;\\\\[[:space:]]*$") "|; "))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("INSTDIR =.*")
+ (string-append "INSTDIR = " out "\n"))
+ (("OWNER = .*")
+ "OWNER = `id -un`\n")
+ (("GROUP = .*")
+ "GROUP = `id -g`\n"))
+ #t)))
+ (replace 'build
+ (lambda _
+ (invoke "make" "-j"
+ (number->string (parallel-job-count))
+ "all" "CC=gcc"))))))
+ (inputs `(("perl" ,perl)))
+ (synopsis "Convert TrueType fonts to Postscript Type 1")
+ (description
+ "TTF2PT1 provides tools to convert most TrueType fonts (or other formats
+supported by the FreeType library) to an Adobe Type 1 @file{.pfa} or
+@file{.pfb} file. Another use is as a hinting engine: feed it an unhinted or
+poorly hinted Adobe Type 1 font through the FreeType library and get it back
+with freshly generated hints. The files produced by default are in
+human-readable form, which further needs to be encoded with t1utilities to
+work with most software requiring Type 1 fonts.")
+ (home-page "http://ttf2pt1.sourceforge.net/")
+ (license license:bsd-3)))
+
(define-public woff2
(let ((commit "4e698b8c6c5e070d53c340db9ddf160e21070ede")
(revision "1"))