summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-24 19:59:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-24 20:22:00 +0300
commitc80f837afdbc1aba1c7c9b6c20710fcd830b0767 (patch)
tree32cc97575a0a80547b23f9916d4bda904b6047ce /gnu/packages/fontutils.scm
parent030030f4416b54285dcdd58bddb863c0e6bda4c4 (diff)
downloadguix-patches-c80f837afdbc1aba1c7c9b6c20710fcd830b0767.tar
guix-patches-c80f837afdbc1aba1c7c9b6c20710fcd830b0767.tar.gz
gnu: fontforge: Update to 20170731.
* gnu/packages/fontutils.scm (fontforge): Update to 20170731. [source]: Remove patch, remove snippet. [arguments]: Enable tests. Remove phase to build showttf. [inputs]: Use python-wrapper instead of python. [home-page]: Update to new home page. * gnu/packages/patches/fontforge-svg-modtime.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm33
1 files changed, 6 insertions, 27 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index bd74c4d6aa..102def93de 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -507,26 +507,14 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20160404")
+ (version "20170731")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
- version "/fontforge-dist-" version ".tar.gz"))
+ version "/fontforge-dist-" version ".tar.xz"))
(sha256 (base32
- "1kavnhbkzc1hk6f39fynq9s0haama81ddrbld4b5x60d0dbaawvc"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Make builds bit-reproducible by using fixed date strings.
- (substitute* "configure"
- (("^FONTFORGE_MODTIME=.*$")
- "FONTFORGE_MODTIME=\"1459819518L\"\n")
- (("^FONTFORGE_MODTIME_STR=.*$")
- "FONTFORGE_MODTIME_STR=\"20:25 CDT 4-Apr-2016\"\n")
- (("^FONTFORGE_VERSIONDATE=.*$")
- "FONTFORGE_VERSIONDATE=\"20160404\"\n"))))
- (patches (list (search-patch "fontforge-svg-modtime.patch")))))
+ "08l8h3yvk4v7652jvmd3ls7nf5miybkx2fmkf1mpwwfixpxxw2l4"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -550,20 +538,11 @@ definitions.")
("libxml2" ,libxml2)
("pango" ,pango)
("potrace" ,potrace)
- ("python" ,python)
+ ("python" ,python-wrapper)
("zlib" ,zlib)))
(arguments
- '(#:tests? #f
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after 'build 'build-contrib
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (and (zero? (system* "make" "-Ccontrib/fonttools"
- "CC=gcc" "showttf"))
- (begin (install-file "contrib/fonttools/showttf" bin)
- #t)))))
(add-after 'install 'set-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -585,4 +564,4 @@ definitions.")
opentype fonts. You can save fonts in many different outline formats, and
generate bitmaps.")
(license license:gpl3+)
- (home-page "http://fontforge.org/")))
+ (home-page "https://fontforge.github.io/en-US/")))