summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-04-20 15:10:54 -0400
committerMark H Weaver <mhw@netris.org>2017-04-21 00:04:34 -0400
commitbab9a8ba0f285a811b7b36291bdc3db33b6c2b60 (patch)
tree45a4f856920786f04f69a360e13902979f0c49cb /gnu/packages/fontutils.scm
parentf920e79426f51f1320dd4ffc164fc473df2158c3 (diff)
downloadguix-patches-bab9a8ba0f285a811b7b36291bdc3db33b6c2b60.tar
guix-patches-bab9a8ba0f285a811b7b36291bdc3db33b6c2b60.tar.gz
gnu: graphite2: Add fixes for CVE-2017-5436 and other bugs.
* gnu/packages/fontutils.scm (graphite2)[replacement]: New field. (graphite2/fixed): New variable. * gnu/packages/patches/graphite2-CVE-2017-5436.patch, gnu/packages/patches/graphite2-check-code-point-limit.patch, gnu/packages/patches/graphite2-fix-32-bit-wrap-arounds.patch, gnu/packages/patches/graphite2-non-linear-classes-even-number.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 7e7234960d..cc6d1df597 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -376,6 +376,7 @@ applications should be.")
(package
(name "graphite2")
(version "1.3.9")
+ (replacement graphite2/fixed)
(source
(origin
(method url-fetch)
@@ -400,6 +401,27 @@ and returns a sequence of positioned glyphids from the font.")
(license license:lgpl2.1+)
(home-page "https://github.com/silnrsi/graphite")))
+(define graphite2/fixed
+ (package
+ (inherit graphite2)
+ (name "graphite2")
+ (version "1.3.9")
+ (replacement #f)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/silnrsi/graphite/releases/"
+ "download/" version "/" name "-" version ".tgz"))
+ (patches (search-patches
+ "graphite2-ffloat-store.patch"
+ "graphite2-check-code-point-limit.patch"
+ "graphite2-CVE-2017-5436.patch"
+ "graphite2-fix-32-bit-wrap-arounds.patch"
+ "graphite2-non-linear-classes-even-number.patch"))
+ (sha256
+ (base32
+ "0rs5h7m340z75kygx8d72cps0q6yvvqa9i788vym7585cfv8a0gc"))))))
+
(define-public potrace
(package
(name "potrace")