summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-16 22:28:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 16:26:20 +0100
commitb1989c12501e880afab62d3ff961791906fef350 (patch)
treeec1cf7a7f80ff803d2af32a53f41102746530a77 /gnu/packages/fontutils.scm
parentfb9d0350153f0e969c0a8e57a698e378158ae124 (diff)
downloadguix-patches-b1989c12501e880afab62d3ff961791906fef350.tar
guix-patches-b1989c12501e880afab62d3ff961791906fef350.tar.gz
gnu: freetype: Fix CVE-2018-6942.
* gnu/packages/patches/freetype-CVE-2018-6942.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/fontutils.scm (freetype)[replacement]: New field. (freetype/fixed): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 664cbdb902..a04441a005 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -54,6 +54,7 @@
(package
(name "freetype")
(version "2.8.1")
+ (replacement freetype/fixed)
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
@@ -78,6 +79,13 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
(home-page "https://www.freetype.org/")))
+(define freetype/fixed
+ (package/inherit freetype
+ (source
+ (origin
+ (inherit (package-source freetype))
+ (patches (search-patches "freetype-CVE-2018-6942.patch"))))))
+
(define-public ttfautohint
(package
(name "ttfautohint")