summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-13 03:16:47 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 02:53:45 +0200
commitacc8a0c10b71c2ece4c0a005f40b551826ef2876 (patch)
treebb4bd3a61e1a1f03ab3a5fbb6ec134c6858ecf88 /gnu/packages/fontutils.scm
parentaa4557a223600f7e6dca89ae6730ca132dda1933 (diff)
downloadguix-patches-acc8a0c10b71c2ece4c0a005f40b551826ef2876.tar
guix-patches-acc8a0c10b71c2ece4c0a005f40b551826ef2876.tar.gz
gnu: woff2: Update package definition.
* gnu/packages/fontutils.scm (woff2): Update package definition. [outputs]: New output "bin". [arguments]<#:configure-flags>[-DCMAKE_INSTALL_BINDIR]: New flag. [-DCMAKE_INSTALL_INCLUDEDIR]: New flag. [-DCMAKE_INSTALL_LIBDIR]: New flag. [-DBUILD_SHARED_LIBS]: Remove flag. <#:phases>['patch-installation]: New phase. [synopsis]: Modify. [description]: Modify. [home-page]: Modify. [license]: Change to expat. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm62
1 files changed, 40 insertions, 22 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 46279301d6..b53365e0d5 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -263,32 +263,50 @@ work with most software requiring Type 1 fonts.")
(package
(name "woff2")
(version "1.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/woff2")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version ".git"))
- (sha256
- (base32
- "13l4g536h0pr84ww4wxs2za439s0xp1va55g6l478rfbb1spp44y"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/google/woff2.git")
+ (commit (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "13l4g536h0pr84ww4wxs2za439s0xp1va55g6l478rfbb1spp44y"))))
(build-system cmake-build-system)
+ (outputs '("out" "bin"))
+ (arguments
+ `(#:tests? #f ; No target
+ #:configure-flags
+ (list
+ (string-append "-DCMAKE_INSTALL_BINDIR="
+ (assoc-ref %outputs "bin")
+ "/bin")
+ (string-append "-DCMAKE_INSTALL_INCLUDEDIR="
+ (assoc-ref %outputs "out")
+ "/include")
+ (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ ;; To install both binaries and libraries.
+ (add-after 'unpack 'patch-installation
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("NOT BUILD_SHARED_LIBS")
+ "BUILD_SHARED_LIBS"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("google-brotli" ,google-brotli)))
- (arguments
- ;; package has no tests
- `(#:tests? #f
- ;; we can’t have both, shared libraries and binaries, so turn off the
- ;; former
- #:configure-flags (list "-DBUILD_SHARED_LIBS=OFF")))
- (synopsis "Compress TrueType fonts to WOFF2")
- (description
- "This package provides utilities for compressing/decompressing TrueType
-fonts to/from the WOFF2 format.")
- (license license:asl2.0)
- (home-page "https://github.com/google/woff2")))
+ `(("brotli" ,google-brotli)))
+ (synopsis "Libraries and tools for WOFF2 font format")
+ (description "WOFF2 provides libraires and tools to handle the Web Open
+Font Format (WOFF).")
+ (home-page "https://w3c.github.io/woff/woff2/")
+ (license license:expat)))
(define-public fontconfig
(package