summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/fontutils.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 120367ada8..d67c5dc466 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +58,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -499,7 +501,7 @@ primary means by which end users perform conversions, and they have not
been designed, tested, and debugged to the extent that general-purpose
applications should be.")
(license license:lgpl2.1+)
- (home-page "http://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
+ (home-page "https://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
(define-public graphite2
(package
@@ -875,7 +877,7 @@ generated list of fallback fonts are checked.")
(define-public fontmanager
(package
(name "fontmanager")
- (version "0.7.7")
+ (version "0.8.4")
(source
(origin
(method git-fetch)
@@ -885,7 +887,7 @@ generated list of fallback fonts are checked.")
(file-name (git-file-name name version))
(sha256
(base32
- "1bzqvspplp1zj0n0869jqbc60wgbjhf0vdrn5bj8dfawxynh8s5f"))))
+ "09rv0srpj8ann2n1zpv1frlpxz0x10d2y21c5lys7pmfngljlxi9"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -895,19 +897,21 @@ generated list of fallback fonts are checked.")
(assoc-ref %outputs "out")
"/lib/font-manager"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("yelp-tools" ,yelp-tools)
+ `(("desktop-file-utils" ,desktop-file-utils)
("gettext" ,gettext-minimal)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("desktop-file-utils" ,desktop-file-utils)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)
+ ("yelp-tools" ,yelp-tools)))
(inputs
- `(("json-glib" ,json-glib)
- ("sqlite" ,sqlite)
- ("fonconfig" ,fontconfig)
+ `(("fonconfig" ,fontconfig)
("freetype" ,freetype)
- ("gtk+" ,gtk+)))
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libsoup" ,libsoup)
+ ("sqlite" ,sqlite)
+ ("webkitgtk" ,webkitgtk)))
(home-page "https://fontmanager.github.io/")
(synopsis "Simple font management for GTK+ desktop environments")
(description "Font Manager is intended to provide a way for users to