summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/fontutils.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 8e0980dd95..2d24e9f047 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -847,7 +847,7 @@ maintain the Noto Fonts project.")
(define-public fcft
(package
(name "fcft")
- (version "2.4.1")
+ (version "2.4.5")
(home-page "https://codeberg.org/dnkl/fcft")
(source (origin
(method git-fetch)
@@ -855,7 +855,7 @@ maintain the Noto Fonts project.")
(file-name (git-file-name name version))
(sha256
(base32
- "00rwh5qfayihrq0wjx8pxqw5ah6g5ym6raxvdbqb6g6rk7m2j423"))))
+ "0z4bqap88pydkgcxrsvm3fmcyhi9x7z8knliarvdcvqlk7qnyzfh"))))
(build-system meson-build-system)
(native-inputs
`(("check" ,check)
@@ -997,18 +997,17 @@ Unicode Charts. It was developed for use with DejaVu Fonts project.")
(define-public libraqm
(package
(name "libraqm")
- (version "0.7.1")
+ (version "0.7.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/HOST-Oman/libraqm/"
- "releases/download/v" version "/"
- "raqm-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/HOST-Oman/libraqm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0a4q9dziirb85sa9rmkamg2krdhd009di2vlz91njwxcp3q8qj46"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags (list "--disable-static")))
+ (base32 "1shcs5l27l7380dvacvhl8wrdq3lix0wnhzvfdh7vx2pkzjs3zk6"))))
+ (build-system meson-build-system)
(native-inputs
`(("gtk-doc" ,gtk-doc/stable)
("pkg-config" ,pkg-config)