summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/fontutils.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadguix-patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar
guix-patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index f9e117b2f4..69e35cda0e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -159,29 +159,30 @@ Converts WOFF fonts to OpenType fonts
(define-public ttf2eot
(package
(name "ttf2eot")
- (version "0.0.2-2")
+ (version "0.0.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://storage.googleapis.com/"
- "google-code-archive-downloads/v2/"
- "code.google.com/ttf2eot/"
- "ttf2eot-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wget/ttf2eot.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1f4dzzmhn0208dvbm3ia5ar6ls9apwc6ampy5blmfxkigi6z0g02"))
+ "0l2yh2ialx7135pjzhjs204kk3br7zxjr09zwaia493by2adzigr"))
(patches (list (search-patch "ttf2eot-cstddef.patch")))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no tests
+ `(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (delete 'configure) ;no configuration
- (replace 'install
+ (delete 'configure) ; no configuration
+ (replace 'install ; no install target
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
- (install-file "ttf2eot" bin)))))))
+ (install-file "ttf2eot" bin)
+ #t))))))
(synopsis "Convert from TrueType to Embeddable Open Type")
(description
"This package contains a commandline wrapper around OpenTypeUtilities.cpp
@@ -191,7 +192,7 @@ TTF (TrueType/OpenType Font) files.")
;; 2/LGPL 2.1", the single derived source file includes only BSD in its
;; license header, and the wrapper source contains no license header.
(license license:bsd-2)
- (home-page "https://code.google.com/archive/p/ttf2eot/")))
+ (home-page "https://github.com/wget/ttf2eot")))
(define-public woff2
(let ((commit "4e698b8c6c5e070d53c340db9ddf160e21070ede")