summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 19:37:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 19:44:51 +0200
commit3e73beaf233f7533b9cafc3d162048560f48a72f (patch)
treed943efbb3f72628b2a24edca818323c0c480eb53 /gnu/packages/fontutils.scm
parent04542d5a6fffbff80fa429c6186098537751b33e (diff)
downloadguix-patches-3e73beaf233f7533b9cafc3d162048560f48a72f.tar
guix-patches-3e73beaf233f7533b9cafc3d162048560f48a72f.tar.gz
gnu: fntsample: Update Blocks.txt and use stable URL.
* gnu/packages/fontutils.scm (fntsample)[input]: Update unicode-blocks to 14.0.0 and include the version in its URL and name.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index d173a1529e..c962777666 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -935,13 +935,15 @@ work well with other GTK+ desktop environments.")
("perl-pdf-api2" ,perl-pdf-api2)
("perl-libintl-perl" ,perl-libintl-perl)
("unicode-blocks"
- ,(origin
- (method url-fetch)
- (uri "https://unicode.org/Public/UNIDATA/Blocks.txt")
- (file-name "unicode-blocks.txt")
- (sha256
- (base32
- "1xs8fnhh48gs41wg004r7m4r2azh9khmyjjlnvyzy9c6zrd212x2"))))))
+ ,(let ((version "14.0.0"))
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://unicode.org/Public/"
+ version "/ucd/Blocks.txt"))
+ (file-name (string-append "unicode-blocks-" version ".txt"))
+ (sha256
+ (base32
+ "05vzgrvfp35mgxjgkm4wnxjjgzva8n6545i9jxd4pczpvvfp122r")))))))
(home-page "https://github.com/eugmes/fntsample")
(synopsis "PDF and PostScript font samples generator")
(description "This package provides a tool that can be used to make font