summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-10-23 23:46:59 -0500
committerEric Bavier <bavier@member.fsf.org>2014-10-26 13:03:53 -0500
commit35b9e4232c1b59568c9a76630251c1ea6a330ac4 (patch)
tree5572758f315e565ab7e9f3fe54867a8813645637 /gnu/packages/fontutils.scm
parent3c42965b1ecd392da7691e5c7e25303ea385bf3d (diff)
downloadguix-patches-35b9e4232c1b59568c9a76630251c1ea6a330ac4.tar
guix-patches-35b9e4232c1b59568c9a76630251c1ea6a330ac4.tar.gz
gnu: Some cleanup based on lint checkers.
* gnu/packages/admin.scm, gnu/packages/aidc.scm, gnu/packages/algebra.scm, gnu/packages/apr.scm, gnu/packages/avahi.scm, gnu/packages/backup.scm, gnu/packages/base.scm, gnu/packages/calcurse.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/compression.scm, gnu/packages/cook.scm, gnu/packages/crypto.scm, gnu/packages/cryptsetup.scm, gnu/packages/curl.scm, gnu/packages/cyrus-sasl.scm, gnu/packages/databases.scm, gnu/packages/doxygen.scm, gnu/packages/dwm.scm, gnu/packages/elf.scm, gnu/packages/emacs.scm, gnu/packages/feh.scm, gnu/packages/file.scm, gnu/packages/fish.scm, gnu/packages/flex.scm, gnu/packages/fltk.scm, gnu/packages/fontutils.scm, gnu/packages/games.scm, gnu/packages/gcal.scm, gnu/packages/gcc.scm, gnu/packages/geeqie.scm, gnu/packages/ghostscript.scm, gnu/packages/gimp.scm, gnu/packages/gl.scm, gnu/packages/glib.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gperf.scm, gnu/packages/grub.scm, gnu/packages/gsasl.scm, gnu/packages/gtk.scm, gnu/packages/guile-wm.scm, gnu/packages/guile.scm, gnu/packages/hurd.scm, gnu/packages/icu4c.scm, gnu/packages/image.scm, gnu/packages/imagemagick.scm, gnu/packages/irssi.scm, gnu/packages/kde.scm, gnu/packages/libdaemon.scm, gnu/packages/libevent.scm, gnu/packages/libidn.scm, gnu/packages/libusb.scm, gnu/packages/linux.scm, gnu/packages/lout.scm, gnu/packages/lsh.scm, gnu/packages/lsof.scm, gnu/packages/lua.scm, gnu/packages/maths.scm, gnu/packages/mcrypt.scm, gnu/packages/mp3.scm, gnu/packages/netpbm.scm, gnu/packages/noweb.scm, gnu/packages/ocaml.scm, gnu/packages/openssl.scm, gnu/packages/pcre.scm, gnu/packages/pdf.scm, gnu/packages/pkg-config.scm, gnu/packages/pretty-print.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/rsync.scm, gnu/packages/scheme.scm, gnu/packages/scrot.scm, gnu/packages/sdl.scm, gnu/packages/skribilo.scm, gnu/packages/ssh.scm, gnu/packages/stalonetray.scm, gnu/packages/tcl.scm, gnu/packages/tcsh.scm, gnu/packages/telephony.scm, gnu/packages/texlive.scm, gnu/packages/tor.scm, gnu/packages/valgrind.scm, gnu/packages/version-control.scm, gnu/packages/vim.scm, gnu/packages/vpn.scm, gnu/packages/w3m.scm, gnu/packages/web.scm, gnu/packages/wordnet.scm, gnu/packages/xiph.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/packages/zile.scm, gnu/packages/zip.scm, gnu/packages/zsh.scm [synopsis, description]: Adjust according to lint checkers. * gnu/packages/fltk.scm (fltk)[source]: Wrap long line in uri. * /gnu/packages/xiph.scm (libogg, libtheora, vorbis-tools)[source]: Same.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 512dbb6406..e383b36b53 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -62,12 +62,12 @@
(symlink (string-append include "/freetype2/freetype")
(string-append include "/freetype"))))
%standard-phases)))
- (synopsis "Freetype, a library to render fonts")
+ (synopsis "Font rendering library")
(description
"Freetype is a library that can be used by applications to access the
-contents of font files. It provides a uniform interface to access font files.
+contents of font files. It provides a uniform interface to access font files.
It supports both bitmap and scalable formats, including TrueType, OpenType,
-Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
+Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
(home-page "http://www.freetype.org/")))
@@ -134,10 +134,10 @@ high quality, anti-aliased and subpixel rendered text on a display.")
It is based on the code of the X11 rasteriser of the X11 project.
The bitmaps created by t1lib are returned in a data structure with type
-GLYPH. This special GLYPH-type is also used in the X11 window system to
-describe character bitmaps. It contains the bitmap data as well as some
-metric information. But t1lib is in itself entirely independent of the
-X11-system or any other graphical user interface. ")
+GLYPH. This special GLYPH-type is also used in the X11 window system to
+describe character bitmaps. It contains the bitmap data as well as some
+metric information. But t1lib is in itself entirely independent of the
+X11-system or any other graphical user interface.")
(license license:gpl2)
(home-page "http://www.t1lib.org/")))
@@ -156,13 +156,13 @@ X11-system or any other graphical user interface. ")
(patches (list (search-patch "teckit-cstdio.patch")))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
- (synopsis "TECkit, a toolkit for encoding conversions")
+ (synopsis "Toolkit for encoding conversions")
(description
"TECkit is a low-level toolkit intended to be used by other applications
that need to perform encoding conversions (e.g., when importing legacy data
-into a Unicode-based application). The primary component of the TECkit
+into a Unicode-based application). The primary component of the TECkit
package is therefore a library that performs conversions; this is the
-\"TECkit engine\". The engine relies on mapping tables in a specific binary
+\"TECkit engine\". The engine relies on mapping tables in a specific binary
format (for which documentation is available); there is a compiler that
creates such tables from a human-readable mapping description (a simple
text file).
@@ -171,7 +171,7 @@ To facilitate the development and testing of mapping tables for TECkit,
several applications are also included in the current package; these
include simple tools for applying conversions to plain-text and Standard
Format files, as well as both command-line and simple GUI versions of the
-TECkit compiler. However, it is not intended that these tools will be the
+TECkit compiler. However, it is not intended that these tools will be the
primary means by which end users perform conversions, and they have not
been designed, tested, and debugged to the extent that general-purpose
applications should be.")
@@ -196,7 +196,7 @@ applications should be.")
`(("freetype" ,freetype)
("perl" ,perl)
("python" ,python-2))) ; because of "import imap" in tests
- (synopsis "reimplementation of the SIL Graphite text processing engine")
+ (synopsis "Reimplementation of the SIL Graphite text processing engine")
(description
"Graphite2 is a reimplementation of the SIL Graphite text processing
engine. Graphite is a smart font technology designed to facilitate the