summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-01 16:22:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:24 -0400
commit2c7e76ed1413fc564e8ce9a7ea7b480a4d74d74a (patch)
treeff95f58b1dce4bfb754e70ef63fdea4efc24c095 /gnu/packages/fontutils.scm
parent9e29cf8d73c39fa65a9d4a107b5db614cb88062a (diff)
downloadguix-patches-2c7e76ed1413fc564e8ce9a7ea7b480a4d74d74a.tar
guix-patches-2c7e76ed1413fc564e8ce9a7ea7b480a4d74d74a.tar.gz
gnu: Add python-defcon-bootstrap.
* gnu/packages/fontutils.scm (python-defcon-bootstrap): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index ec6dab37ff..61b39e510d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -821,6 +821,36 @@ generate bitmaps.")
files. UFO is a file format that stores fonts source files.")
(license license:bsd-3)))
+;;; A variant used to break a cycle between python-fontpens and
+;;; python-fontparts.
+(define-public python-defcon-bootstrap
+ (package
+ (name "python-defcon-bootstrap")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "defcon" version ".zip"))
+ (sha256
+ (base32 "0g0bjwzdj6sskyh8snbxsxza3czdmvb807qv38mizx631cm8c2d0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-fontpens-bootstrap python-fonttools-full))
+ (native-inputs
+ (list python-pytest
+ python-pytest-runner
+ python-setuptools-scm
+ unzip))
+ (home-page "https://github.com/robotools/defcon")
+ (synopsis "Flexible objects for representing @acronym{UFO, unified font object} data")
+ (description "Defcon is a set of @acronym{UFO, unified font object} based
+objects optimized for use in font editing applications. The objects are built
+to be lightweight, fast and flexible. The objects are very bare-bones and
+they are not meant to be end-all, be-all objects. Rather, they are meant to
+provide base functionality so that you can focus on your application’s
+behavior, not object observing or maintaining cached data. Defcon implements
+UFO3 as described by the UFO font format.")
+ (license license:expat)))
+
(define-public python2-defcon
(package
(name "python2-defcon")