summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 00:09:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:26 -0400
commit0ce611f56397092ac963efac71be3d509f035733 (patch)
tree122fa4210b6ab399d4d7c9140f9d6ae4fec534ab /gnu/packages/fontutils.scm
parent19cb21c749d8eb3331347884ed18f6c730226560 (diff)
downloadguix-patches-0ce611f56397092ac963efac71be3d509f035733.tar
guix-patches-0ce611f56397092ac963efac71be3d509f035733.tar.gz
gnu: Add python-defcon.
* gnu/packages/fontutils.scm (python-defcon): New variable. (python2-defcon): Adjust to inherit from it.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm36
1 files changed, 16 insertions, 20 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index e8839fdca7..503ff7afa3 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -960,35 +960,31 @@ behavior, not object observing or maintaining cached data. Defcon implements
UFO3 as described by the UFO font format.")
(license license:expat)))
+(define-public python-defcon
+ (hidden-package
+ (package/inherit python-defcon-bootstrap
+ (name "python-defcon")
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-defcon-bootstrap)
+ (replace "python-fontpens-bootstrap" python-fontpens))))))
+
(define-public python2-defcon
(package
+ (inherit python-defcon)
(name "python2-defcon")
(version "0.3.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "defcon" version ".zip"))
- (sha256
- (base32
- "03jlm2gy9lvbwj68kfdm43yaddwd634jwkdg4wf0jxx2s8mwbg22"))))
- (build-system python-build-system)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "defcon" version ".zip"))
+ (sha256
+ (base32
+ "03jlm2gy9lvbwj68kfdm43yaddwd634jwkdg4wf0jxx2s8mwbg22"))))
(arguments
`(#:python ,python-2))
(native-inputs
(list unzip python2-pytest python2-pytest-runner))
(propagated-inputs
- (list python2-fonttools python2-ufolib))
- (home-page "https://pypi.org/project/defcon/")
- (synopsis "Flexible objects for representing @acronym{UFO, unified font object} data")
- (description
- "Defcon is a set of @acronym{UFO, unified font object} based objects
-optimized for use in font editing applications. The objects are built to
-be lightweight, fast and flexible. The objects are very bare-bones and
-they are not meant to be end-all, be-all objects. Rather, they are meant
-to provide base functionality so that you can focus on your application’s
-behavior, not object observing or maintaining cached data. Defcon
-implements UFO3 as described by the UFO font format.")
- (license license:expat)))
+ (list python2-fonttools python2-ufolib))))
(define-public nototools
(package