summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-06-16 11:17:13 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-06-17 21:09:19 +0530
commitc226f06c5960069a343a6de663a07b5d75027ca6 (patch)
treec8b5808b9db091c01b9455bced9ac3531124c162 /gnu/packages/fonts.scm
parent40b784b4c7c1750b17f4c5a801f784e4d69b1647 (diff)
downloadguix-patches-c226f06c5960069a343a6de663a07b5d75027ca6.tar
guix-patches-c226f06c5960069a343a6de663a07b5d75027ca6.tar.gz
gnu: font-tex-gyre: Use 'font-build-system'.
* gnu/packages/fonts.scm (font-tex-gyre): Switch to font-build-system. [source]: Use url-fetch/zipbomb.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 59e60dc292..50021aad1d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -555,28 +555,13 @@ fonts.")
(version "2.005")
(source
(origin
- (method url-fetch)
+ (method url-fetch/zipbomb)
(uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
"tex-gyre/whole/tg-" version "otf.zip"))
(sha256
(base32
"0kph9l3g7jb2bpmxdbdg5zl56wacmnvdvsdn7is1gc750sqvsn31"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
-
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
- (font-dir (string-append %output "/share/fonts/opentype")))
- (mkdir-p font-dir)
- (system* unzip
- (assoc-ref %build-inputs "source")
- "-d" font-dir)))))
- (native-inputs
- `(("unzip" ,unzip)))
+ (build-system font-build-system)
(home-page "http://www.gust.org.pl/projects/e-foundry/tex-gyre/")
(synopsis "Remake of Ghostscript fonts")
(description "The TeX Gyre collection of fonts is the result of an