summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 21:59:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 22:09:19 +0100
commita431e213835cc47fcddc55d1e2f4b7201404fde5 (patch)
tree9fd7e4d7422dccdef071f0d322b079abf08b2b79 /gnu/packages/fonts.scm
parent223055dd3f09d1742cc706edfd7bb283100f1793 (diff)
downloadguix-patches-a431e213835cc47fcddc55d1e2f4b7201404fde5.tar
guix-patches-a431e213835cc47fcddc55d1e2f4b7201404fde5.tar.gz
gnu: font-terminus: Install X11 8-bit code pages.
* gnu/packages/fonts.scm (font-terminus)[outputs]: Add ‘pcf-8bit’ output. [arguments]: Add new phases to build and install these 8-bit PCF fonts.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index bb8548c1eb..e6867996ca 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -353,14 +353,28 @@ Biolinum is available in both Regular and Bold weights.")
(sha256
(base32 "15qjcpalcxjiwsjgjg5k88vkwp56cs2nnx4ghya6mqp4i1c206qg"))))
(build-system gnu-build-system)
+ (outputs (list "out" "pcf-8bit"))
+ (arguments
+ `(#:tests? #f ; no test target in tarball
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'build-more-bits
+ ;; X11 8-bit code pages aren't installed by default (they were
+ ;; until version 4.46). Build and install them separately.
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "pcf-8bit" make-flags)))
+ (add-after 'install 'install-more-bits
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let ((pcf-8bit (assoc-ref outputs "pcf-8bit")))
+ (apply invoke "make" "install-pcf-8bit" (string-append "prefix="
+ pcf-8bit)
+ make-flags)))))))
(native-inputs
`(("bdftopcf" ,bdftopcf)
("font-util" ,font-util)
("mkfontdir" ,mkfontdir)
("pkg-config" ,pkg-config)
("python" ,python)))
- (arguments
- `(#:tests? #f)) ; no test target in tarball
(home-page "http://terminus-font.sourceforge.net/")
(synopsis "Simple bitmap programming font")
(description "Terminus Font is a clean, fixed-width bitmap font, designed