summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-22 11:55:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-22 12:35:22 +0300
commit6fc9c6f7d96f44fa72ef64ebbd40a6f27a63a1e1 (patch)
treea77b8c621f99ba3913d61c8c6a6b4f8469f5bec0 /gnu/packages/fonts.scm
parentb090bdc9f592b85e394e88b3d2c3c0e9ecbd75ac (diff)
downloadguix-patches-6fc9c6f7d96f44fa72ef64ebbd40a6f27a63a1e1.tar
guix-patches-6fc9c6f7d96f44fa72ef64ebbd40a6f27a63a1e1.tar.gz
gnu: font-awesome: Download using git-fetch.
The official link on the website has a regularly changing hash. * gnu/packages/fonts.scm (font-awesome)[source]: Use 'git-fetch'. [arguments]: Replace 'install phase. [home-page]: Use new upstream home-page.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 03bfa43014..bb6dc45d94 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1000,14 +1000,31 @@ correct spacing.")
;; <https://bugs.gnu.org/32916>
(version "4.7.0")
(source (origin
- (method url-fetch)
- (uri (string-append "http://fontawesome.io/assets/"
- name "-" version ".zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FortAwesome/Font-Awesome.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1m1rfwm4sjkv10j3xd2dhwk286a5912b2zgvc692cmxi5gxs68jf"))))
+ "0w30y26jp8nvxa3iiw7ayl6rkza1rz62msl9xw3srvxya1c77grc"))))
(build-system font-build-system)
- (home-page "http://fontawesome.io")
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (source (string-append (getcwd) "/fonts"))
+ (fonts (string-append out "/share/fonts")))
+ (for-each (lambda (file)
+ (install-file file (string-append fonts "/truetype")))
+ (find-files source "\\.(ttf|ttc)$"))
+ (for-each (lambda (file)
+ (install-file file (string-append fonts "/opentype")))
+ (find-files source "\\.(otf|otc)$"))
+ #t))))))
+ (home-page "https://fontawesome.com/")
(synopsis "Font that contains a rich iconset")
(description
"Font Awesome is a full suite of pictographic icons for easy scalable