summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-10 01:25:28 +0000
committerLudovic Courtès <ludo@gnu.org>2019-11-19 10:51:53 +0100
commit600f680dca7f1755d47df4394b794b4c7fee3aa5 (patch)
tree229d8482dbf89125584361bf667a7babcf5dbc21 /gnu/packages/fonts.scm
parente30bb63c2905f5548a1c66d076ef7e18338d9bc8 (diff)
downloadguix-patches-600f680dca7f1755d47df4394b794b4c7fee3aa5.tar
guix-patches-600f680dca7f1755d47df4394b794b4c7fee3aa5.tar.gz
gnu: Add font-dseg.
* gnu/packages/fonts.scm (font-dseg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index bb6dc45d94..83c97444bf 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Alva <alva@skogen.is>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1524,3 +1525,43 @@ Symbols stand out from common text. Dots and commas are easily seen, and
operators are clear even when not surrounded by spaces. Similar characters
have been designed to be very distinguishable from each other.")
(license license:silofl1.1)))
+
+(define-public font-dseg
+ (package
+ (name "font-dseg")
+ (version "0.45")
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri
+ (string-append "https://github.com/keshikan/DSEG/"
+ "releases/download/v" version
+ "/fonts-DSEG_v"
+ (string-concatenate (string-split version #\.))
+ ".zip"))
+ (sha256
+ (base32
+ "0v8sghh4vl286faf8pvi74znz07pyf0qii8z4wjllisqwc35sx72"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (font-dir (string-append out "/share/fonts"))
+ (truetype-dir (string-append font-dir "/truetype")))
+ (with-directory-excursion
+ (string-append "fonts-DSEG_v"
+ (apply string-append (string-split ,version
+ #\.)))
+ (for-each (lambda (f) (install-file f truetype-dir))
+ (find-files "." "\\.ttf$"))
+ #t)))))))
+ (home-page "https://www.keshikan.net/fonts-e.html")
+ (synopsis "DSEG: 7-segment and 14-segment fonts")
+ (description
+ "DSEG is a font family that imitates seven- and fourteen-segment LCD
+displays (7SEG, 14SEG). DSEG includes the roman alphabet and symbol glyphs.
+This package provides the TrueType fonts.")
+ (license license:silofl1.1)))