summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorSarah Morgensen via Guix-patches via <guix-patches@gnu.org>2021-06-16 17:05:24 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-18 12:13:23 +0200
commit555d14eba701014da257f6d4d58d7e564713bb88 (patch)
tree651f20ff0e10b0a401caf6b46dcc768950521f63 /gnu/packages/fonts.scm
parent93db7fa739f3116a33ec0e61b1a237bda326089a (diff)
downloadguix-patches-555d14eba701014da257f6d4d58d7e564713bb88.tar
guix-patches-555d14eba701014da257f6d4d58d7e564713bb88.tar.gz
gnu: Add font-overpass.
* gnu/packages/fonts.scm (font-overpass): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index fe4d3efb5e..654906ee2a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2176,3 +2177,32 @@ neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
typeface and rescue the beauty of urban typography that emerged in the first
half of the twentieth century.")
(license license:silofl1.1)))
+
+(define-public font-overpass
+ (package
+ (name "font-overpass")
+ (version "3.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RedHatOfficial/Overpass")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pl7zpwlx0j2xv23ahnpmbb4a5d6ib2cjck5mxqzi3jjk25rk9kb"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-webfonts
+ (lambda _
+ (delete-file-recursively "webfonts"))))))
+ (home-page "https://overpassfont.org")
+ (synopsis "Sans serif font family inspired by Highway Gothic")
+ (description
+ "Overpass is a sans-serif typeface based on the U.S. interstate highway
+road signage typefaces, adapted for on-screen display and user interfaces.
+Overpass includes proprotional and monospace variants.")
+ (license (list license:silofl1.1
+ license:lgpl2.1))))