summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2019-05-13 00:37:39 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-14 12:11:04 +0200
commit50867421f91e16aab6d66a1c1707d32434273c50 (patch)
tree4b70d3254f912db6477c33db786065d76b0e4c91 /gnu/packages/fonts.scm
parent8d080506f4957e67d4e6d969f2743870db168abf (diff)
downloadguix-patches-50867421f91e16aab6d66a1c1707d32434273c50.tar
guix-patches-50867421f91e16aab6d66a1c1707d32434273c50.tar.gz
gnu: Add font-hermit
* gnu/packages/fonts.scm (font-hermit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3db933e5ac..a3c695fbda 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1448,3 +1449,39 @@ formatting.")
"Public Sans is a strong, neutral, sans-serif typeface for text or
display based on Libre Franklin.")
(license license:silofl1.1)))
+
+(define-public font-hermit
+ (package
+ (name "font-hermit")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://pcaro.es/d/otf-hermit-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09rmy3sbf1j1hr8zidighjgqc8kp0wsra115y27vrnlf10ml6jy0"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ ;; the tarball provided does not contain a directory
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (invoke "tar" "xvf" source "-C" "source")
+ (chdir "source")
+ #t)))))
+ (home-page "https://pcaro.es/p/hermit/")
+ (synopsis "Monospace font")
+ (description
+ "Hermit is a monospace font designed to be clear, pragmatic and very
+readable. Its creation has been focused on programming. Every glyph was
+carefully planned and calculated, according to defined principles and rules.
+For this reason, Hermit is coherent and regular.
+
+Symbols stand out from common text. Dots and commas are easily seen, and
+operators are clear even when not surrounded by spaces. Similar characters
+have been designed to be very distinguishable from each other.")
+ (license license:silofl1.1)))