summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-05-14 14:47:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-05-14 14:47:44 +0300
commit1731b29742bb2abb24fb0000ea00b3f35b5133bc (patch)
treeebdf9cd163ea84945aad61cf3c9f21c9c7cde7eb /gnu/packages/fonts.scm
parent45d41c035ec23d68f67b69255a5ab8f02b42a5ed (diff)
downloadguix-patches-1731b29742bb2abb24fb0000ea00b3f35b5133bc.tar
guix-patches-1731b29742bb2abb24fb0000ea00b3f35b5133bc.tar.gz
gnu: font-hermit: Download as 'url-fetch/tarbomb'.
* gnu/packages/fonts.scm (font-hermit)[source]: Use 'url-fetch/tarbomb' method. [arguments]: Remove custom phases.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a3c695fbda..72ed0b5207 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1455,7 +1455,7 @@ display based on Libre Franklin.")
(name "font-hermit")
(version "2.0")
(source (origin
- (method url-fetch)
+ (method url-fetch/tarbomb)
(uri (string-append "https://pcaro.es/d/otf-hermit-" version
".tar.gz"))
(sha256
@@ -1463,16 +1463,7 @@ display based on Libre Franklin.")
"09rmy3sbf1j1hr8zidighjgqc8kp0wsra115y27vrnlf10ml6jy0"))))
(build-system font-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'unpack
- ;; the tarball provided does not contain a directory
- (lambda* (#:key source #:allow-other-keys)
- (mkdir "source")
- (invoke "tar" "xvf" source "-C" "source")
- (chdir "source")
- #t)))))
+ `(#:tests? #f))
(home-page "https://pcaro.es/p/hermit/")
(synopsis "Monospace font")
(description