summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-08 16:51:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-25 02:00:05 +0100
commit0d197a63d1c2751c562f44046b089017cd246574 (patch)
treef31c2f70cd1d196b38f2b0916246c3630ca41e30 /gnu/packages/fonts.scm
parent679d41b4406d30ec5805ee8015d2ffa446a4e334 (diff)
downloadguix-patches-0d197a63d1c2751c562f44046b089017cd246574.tar
guix-patches-0d197a63d1c2751c562f44046b089017cd246574.tar.gz
gnu: font-fantasque-sans: Update to 1.8.0.
* gnu/packages/fonts.scm (font-fantasque-sans): Update to 1.8.0. [native-inputs]: Remove ttf2eot. [arguments]: Rename the ‘xrange->range’ phase to ‘support-python@3’. Patch another Python twoism.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b248b27ce2..186e1eecff 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -781,7 +781,7 @@ It contains the following fonts and styles:
(define-public font-fantasque-sans
(package
(name "font-fantasque-sans")
- (version "1.7.2")
+ (version "1.8.0")
(source
(origin
(method git-fetch)
@@ -790,26 +790,27 @@ It contains the following fonts and styles:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1gjranq7qf20rfxnpxsckv1hl35nzsal0rjs475nhfbpqy5wmly6"))))
+ (base32 "17l18488qyl9gdj80r8pcym3gp3jkgsdikwalnrp5rgvwidqx507"))))
(build-system gnu-build-system)
(native-inputs
`(("ttfautohint" ,ttfautohint)
("woff-tools" ,woff-tools)
("fontforge" ,fontforge)
("woff2" ,woff2)
- ("ttf2eot" ,ttf2eot)
("zip" ,zip)))
(arguments
`(#:tests? #f ;test target intended for visual inspection
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configuration
- (add-before 'build 'xrange->range
- ;; Rather than use a python2 fontforge, just replace the
- ;; offending function.
+ (add-before 'build 'support-python@3
+ ;; Rather than use a Python 2 fontforge, replace Python-2-
+ ;; specific code with a passable Python 3 equivalent.
(lambda _
(substitute* "Scripts/fontbuilder.py"
(("xrange") "range"))
+ (substitute* "Scripts/features.py"
+ (("f\\.write\\(fea_code\\)")
+ "f.write(str.encode(fea_code))"))
#t))
(replace 'install
;; 'make install' wants to install to ~/.fonts, install to