summaryrefslogtreecommitdiff
path: root/gnu/packages/fltk.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-01-25 09:27:14 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-25 16:39:03 +0100
commitb6cbb314d9fb31b60a73644c260091c27ac52563 (patch)
tree43b5280381e3588d35c914df0c48462f27ed739b /gnu/packages/fltk.scm
parent3c9aa5c12d0522069555952af9670f1b7c4b5a85 (diff)
downloadguix-patches-b6cbb314d9fb31b60a73644c260091c27ac52563.tar
guix-patches-b6cbb314d9fb31b60a73644c260091c27ac52563.tar.gz
gnu: fltk: New module
* gnu/packages/fltk.scm: New file * gnu-system.am: New file fltk.scm Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fltk.scm')
-rw-r--r--gnu/packages/fltk.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
new file mode 100644
index 0000000000..4c8fc3f2c7
--- /dev/null
+++ b/gnu/packages/fltk.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fltk)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages gl)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public fltk
+ (package
+ (name "fltk")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://fltk.org/pub/fltk/" version "/fltk-" version "-source.tar.gz"))
+ (sha256
+ (base32
+ "1974brlk723095vf8z72kazq1cbqr9a51kq6b0xda6zkjkgl8q0p"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("mesa" ,mesa)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'check
+ (lambda* (#:key inputs #:allow-other-keys) #t) ;; fltk does not have a
+ ;; check target
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ (substitute* "makeinclude.in"
+ (("/bin/sh") (which "sh")))
+ (apply configure args)))
+ %standard-phases))))
+ (home-page "https://www.fltk.org")
+ (synopsis "3D C++ GUI library")
+ (description "FLTK is a C++ GUI toolkit providing modern GUI functionality without the
+bloat. It supports 3D graphics via OpenGL and its built-in GLUT emulation.
+FLTK is designed to be small and modular enough to be statically linked, but
+works fine as a shared library. FLTK also includes an excellent UI builder
+called FLUID that can be used to create applications in minutes.")
+ (license lgpl2.0))) ; plus certain additional permissions