summaryrefslogtreecommitdiff
path: root/gnu/packages/fltk.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-05-05 00:38:59 -0500
committerEric Bavier <bavier@member.fsf.org>2015-05-05 00:52:53 -0500
commit401f9a8b15b126dc6b8a357474f89ae7cb915601 (patch)
tree0dd539ec0e95cda39bca68b5e76120d627d05838 /gnu/packages/fltk.scm
parent21481a284af7b7e9ad33fe072fde9d2ee3274017 (diff)
downloadguix-patches-401f9a8b15b126dc6b8a357474f89ae7cb915601.tar
guix-patches-401f9a8b15b126dc6b8a357474f89ae7cb915601.tar.gz
gnu: fltk: Fix undefined symbol errors for shared libraries.
* gnu/packages/patches/fltk-shared-lib-defines.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/fltk.scm (source)[patches]: New field.
Diffstat (limited to 'gnu/packages/fltk.scm')
-rw-r--r--gnu/packages/fltk.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
index 1ac1f2507e..cbd9d00e8c 100644
--- a/gnu/packages/fltk.scm
+++ b/gnu/packages/fltk.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,6 +19,7 @@
(define-module (gnu packages fltk)
#:use-module (guix licenses)
+ #:use-module (gnu packages)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gl)
#:use-module (guix packages)
@@ -35,7 +37,8 @@
"/fltk-" version "-source.tar.gz"))
(sha256
(base32
- "15qd7lkz5d5ynz70xhxhigpz3wns39v9xcf7ggkl0792syc8sfgq"))))
+ "15qd7lkz5d5ynz70xhxhigpz3wns39v9xcf7ggkl0792syc8sfgq"))
+ (patches (list (search-patch "fltk-shared-lib-defines.patch")))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)