summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-27 22:06:38 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-27 22:06:38 +0200
commit55f0336630a1ed63e6c49985df50dc5d5684b856 (patch)
tree4ae22efdc5b02ec11eafea6459666472fdc990f0 /gnu/packages/flex.scm
parentd6f10ca3fe56709d9a43d3d7e0bfda73e9affa3a (diff)
downloadguix-patches-55f0336630a1ed63e6c49985df50dc5d5684b856.tar
guix-patches-55f0336630a1ed63e6c49985df50dc5d5684b856.tar.gz
gnu: bison: Update to 3.0.
* gnu/packages/bison.scm (bison): Update to 3.0. Make Perl a native input. Add a variant of Flex as a native input. Use #:export instead of 'define-public'. * gnu/packages/flex.scm (flex): Use #:export instead of 'define-public'.
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 5548dcf05d..beddb620a7 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,9 +24,10 @@
#:use-module (gnu packages)
#:use-module (gnu packages m4)
#:use-module (gnu packages bison)
- #:use-module (gnu packages indent))
+ #:use-module (gnu packages indent)
+ #:export (flex))
-(define-public flex
+(define flex
(package
(name "flex")
(version "2.5.37")