summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-29 22:34:20 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-29 22:34:20 +0200
commit06172df545f1253463bc51a9e2c39bf2133f3f23 (patch)
treedd32fbd0e70617068a54a362a32f761794ce880a /gnu/packages/flex.scm
parent5cc1075a76392666d3d733837f5c6252b1e48002 (diff)
downloadguix-patches-06172df545f1253463bc51a9e2c39bf2133f3f23.tar
guix-patches-06172df545f1253463bc51a9e2c39bf2133f3f23.tar.gz
gnu: flex: Build bison-for-tests sequentially.
This is a followup to b1593c1c4fd8f4fc6df4c43cab51334426e3aa76. * gnu/packages/flex.scm (flex)[inputs](bison-for-tests): Use 'substitute-keyword-arguments' instead of overriding them altogether. This ensures that #:parallel-build? and #:parallel-tests? are preserved.
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index e08b0c13db..6038e92744 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -22,6 +22,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages m4)
#:use-module (gnu packages man)
@@ -47,8 +48,10 @@
(let ((bison-for-tests
(package
(inherit bison)
- ;; Disable tests, since they require flex.
- (arguments '(#:tests? #f))
+ (arguments
+ ;; Disable tests, since they require flex.
+ (substitute-keyword-arguments (package-arguments bison)
+ ((#:tests? _ #f) #f)))
(inputs (alist-delete "flex" (package-inputs bison))))))
`(("bison" ,bison-for-tests)
("indent" ,indent))))