summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-05-29 17:28:04 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-01 22:26:06 +0200
commitaf3166c33504237e3af3feda080d2aeff35b3a69 (patch)
tree06bec2b62c5fa23fc32367063b74fabe242cf3cb /gnu/packages/flashing-tools.scm
parentb2e13aa287ef366aa6374dc915520199ef5589ad (diff)
downloadguix-patches-af3166c33504237e3af3feda080d2aeff35b3a69.tar
guix-patches-af3166c33504237e3af3feda080d2aeff35b3a69.tar.gz
gnu: Add dfu-util.
* gnu/packages/flashing-tools.scm (dfu-util): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 9f9f1b9c6a..37a10726e3 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,6 +32,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages libftdi)
#:use-module (gnu packages pciutils)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages admin))
(define-public flashrom
@@ -130,3 +133,30 @@ technique (ISP).")
Atmel (8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting
ISP.")
(license gpl2+)))
+
+(define-public dfu-util
+ (package
+ (name "dfu-util")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://dfu-util.sourceforge.net/releases/dfu-util-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0czq73m92ngf30asdzrfkzraag95hlrr74imbanqq25kdim8qhin"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libusb" ,libusb)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Host side of the USB Device Firmware Upgrade (DFU) protocol")
+ (description
+ "The DFU (Universal Serial Bus Device Firmware Upgrade) protocol is
+intended to download and upload firmware to devices connected over USB. It
+ranges from small devices like micro-controller boards up to mobile phones.
+With dfu-util you are able to download firmware to your device or upload
+firmware from it.")
+ (home-page "http://dfu-util.sourceforge.net/")
+ (license gpl2+)))