summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-02-13 23:48:09 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-15 12:05:24 +0100
commit9721c0b6ef80f10edb3f0bcf5d95033f701554f2 (patch)
treedac4376ff3da5ae2a447b29a6abfff527393f90d /gnu/packages/flashing-tools.scm
parent501e18471610ba9942567ce8c2d4ad40182bd141 (diff)
downloadguix-patches-9721c0b6ef80f10edb3f0bcf5d95033f701554f2.tar
guix-patches-9721c0b6ef80f10edb3f0bcf5d95033f701554f2.tar.gz
gnu: Add intelmetool.
* gnu/packages/flashing-tools.scm (intelmetool): New variable.
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 2a89b6ab0a..08073bac79 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libusb)
#:use-module (gnu packages libftdi)
@@ -363,3 +364,41 @@ referred to as the \"Odin 3 protocol\".")
(description "This package provides @ifdtool}, a program to
dump Intel Firmware Descriptor data of an image file.")
(license license:gpl2)))
+
+(define-public intelmetool
+ (package
+ (name "intelmetool")
+ (version "4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/p/coreboot")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nw555i0fm5kljha9h47bk70ykbwv8ddfk6qhz6kfqb79vzhy4h2"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("pciutils" ,pciutils)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ "INSTALL=install"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/intelmetool")
+ #t))
+ (delete 'configure)
+ (delete 'check))))
+ (home-page "https://github.com/zamaudio/intelmetool")
+ (synopsis "Intel ME tools")
+ (description "This package provides tools for working with Intel
+Management Engine (ME). You need to @code{sudo rmmod mei_me} and
+@code{sudo rmmod mei} before using this tool. Also pass
+@code{iomem=relaxed} to the Linux kernel command line.")
+ (license license:gpl2)))