summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:06:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 06:25:24 +0200
commit17499793b180f29e4040efc96ce06cdc2653c42e (patch)
tree7fe54c32d4815081338e3f3465b2b9f491be1369 /gnu/packages/flashing-tools.scm
parent06effaf6a123f06ee1f4322214acf9c2bd7d67ac (diff)
downloadguix-patches-17499793b180f29e4040efc96ce06cdc2653c42e.tar
guix-patches-17499793b180f29e4040efc96ce06cdc2653c42e.tar.gz
gnu: flashrom: Update to 1.0.1.
* gnu/packages/flashing-tools.scm (flashrom): Update to 1.0.1. [arguments]: Remove CFLAGS work-around.
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 20e14417e4..d9c663d7f4 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -48,16 +48,15 @@
(define-public flashrom
(package
(name "flashrom")
- ;; XXX: The CFLAGS=... line below can probably be removed when updating.
- (version "1.0")
+ (version "1.0.1")
(source (origin
(method url-fetch)
(uri (string-append
- "https://download.flashrom.org/releases/flashrom-"
+ "https://download.flashrom.org/releases/flashrom-v"
version ".tar.bz2"))
(sha256
(base32
- "0r7fkpfc8w51n8ffbhclj4wa3kwrk0ijv1acwpw5myx5bchzl0ip"))))
+ "0i6yrrl69hrqmwd7azj7x3j46m0qpvzmk3b5basym7mnlpfzhyfm"))))
(build-system gnu-build-system)
(inputs `(("dmidecode" ,dmidecode)
("pciutils" ,pciutils)
@@ -67,9 +66,6 @@
(arguments
'(#:make-flags
(list "CC=gcc"
- ;; The default includes ‘-Wall -Werror’, causing the build to fail
- ;; with deprecation warnings against libusb versions >= 1.0.22.
- "CFLAGS=-Os -Wshadow"
(string-append "PREFIX=" %output)
"CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
#:tests? #f ; no 'check' target