summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-14 22:09:06 +0200
committerLeo Famulari <leo@famulari.name>2016-09-23 19:03:19 -0400
commit03ddad84bae4c862c728f617ff70734df709bf63 (patch)
treea537be0ebfc3642500de2b9f545133a1f50e45af /gnu/packages/flashing-tools.scm
parent0f5de84e983bdb65db261ecf5963d4208a8474e4 (diff)
downloadguix-patches-03ddad84bae4c862c728f617ff70734df709bf63.tar
guix-patches-03ddad84bae4c862c728f617ff70734df709bf63.tar.gz
gnu: flashrom: Update to 0.9.9
* gnu/packages/flashing-tools.scm (flashrom): Update to 0.9.9. [source]: Use HTTPS URL. Remove "flashrom-use-libftdi1.patch". [aruments]: Add 'CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no' to #:make-flags. * gnu/packages/patches/flashrom-use-libftdi1.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index d0c164eff4..a55ed96edd 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -38,16 +38,15 @@
(define-public flashrom
(package
(name "flashrom")
- (version "0.9.7")
+ (version "0.9.9")
(source (origin
(method url-fetch)
(uri (string-append
- "http://download.flashrom.org/releases/flashrom-"
+ "https://download.flashrom.org/releases/flashrom-"
version ".tar.bz2"))
(sha256
(base32
- "1s9pc4yls2s1gcg2ar4q75nym2z5v6lxq36bl6lq26br00nj2mas"))
- (patches (search-patches "flashrom-use-libftdi1.patch"))))
+ "0i9wg1lyfg99bld7d00zqjm9f0lk6m0q3h3n9c195c9yysq5ccfb"))))
(build-system gnu-build-system)
(inputs `(("dmidecode" ,dmidecode)
("pciutils" ,pciutils)
@@ -55,7 +54,9 @@
("libftdi" ,libftdi)))
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
- '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ '(#:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output)
+ "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
#:tests? #f ; no 'check' target
#:phases
(alist-delete