summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-03-06 08:24:01 +0100
committerRutger Helling <rhelling@mykolab.com>2018-03-06 08:27:07 +0100
commitcee03b267cbe6e7360b106095ee2861bf010f915 (patch)
tree005db12ee29c7b9e888ba9c594b0e43dcadfc320 /gnu/packages/firmware.scm
parent0f2778029a536ceac93208f2e66af9d3e1ef44a7 (diff)
downloadguix-patches-cee03b267cbe6e7360b106095ee2861bf010f915.tar
guix-patches-cee03b267cbe6e7360b106095ee2861bf010f915.tar.gz
gnu: ovmf: Fix build and add FIXME.
* gnu/packages/firmware.scm (ovmf): Replace 'invoke' with 'system*'. Add FIXME about failing script.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index da7430b063..714af3df72 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -258,7 +258,9 @@ coreboot.")
(setenv "WORKSPACE" cwd)
(setenv "EDK_TOOLS_PATH" tools)
(setenv "PATH" (string-append (getenv "PATH") ":" bin))
- (invoke "bash" "edksetup.sh" "BaseTools")
+ ; FIXME: The below script errors out. When using 'invoke' instead
+ ; of 'system*' this causes the build to fail.
+ (system* "bash" "edksetup.sh" "BaseTools")
(substitute* "Conf/target.txt"
(("^TARGET[ ]*=.*$") "TARGET = RELEASE\n")
(("^TOOL_CHAIN_TAG[ ]*=.*$") "TOOL_CHAIN_TAG = GCC49\n")