summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-04 15:29:01 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-04 15:36:00 +0100
commitbd2e1a8cb07088bdc54b9bb05d9b2e99f78e5b28 (patch)
treecdce3cb091fe096783e12fa1e977a028ab0e9b6b /gnu/packages/firmware.scm
parentfb77c61422ae2d03c0bf655d96b0e88f5f8001da (diff)
downloadguix-patches-bd2e1a8cb07088bdc54b9bb05d9b2e99f78e5b28.tar
guix-patches-bd2e1a8cb07088bdc54b9bb05d9b2e99f78e5b28.tar.gz
gnu: cross-base: Remove exports of cross compilers.
They were never really needed and caused troubles in the presence of circular module dependencies as reported by Danny Milosavljevic <dannym@scratchpost.org> at <https://lists.gnu.org/archive/html/guix-devel/2016-11/msg00144.html>. * gnu/packages/cross-base.scm (xgcc-mips64el, xgcc-xtensa, xgcc-armhf): Remove. * gnu/packages/firmware.scm (ath9k-htc-firmware)[native-inputs]: Use 'cross-gcc' instead of XGCC-XTENSA.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 45b7bf7ab1..484896f592 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,7 +71,7 @@
;; The firmware is cross-compiled using a "bare bones" compiler (no libc.)
;; Use our own tool chain for that.
- (native-inputs `(("cross-gcc" ,xgcc-xtensa)
+ (native-inputs `(("cross-gcc" ,(cross-gcc "xtensa-elf"))
("cross-binutils" ,(cross-binutils "xtensa-elf"))
("cmake" ,cmake)
("perl" ,perl)))