summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-09 16:34:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-09 21:16:54 +0200
commitae623b3f9d53c054cc9cd794108d9df6b02ff570 (patch)
treea87226ca3471f8161763e3a6100166da3aa81010 /gnu/packages/firmware.scm
parent05de4c346da1607eb4f1b3db56ce0935509fa458 (diff)
downloadguix-patches-ae623b3f9d53c054cc9cd794108d9df6b02ff570.tar
guix-patches-ae623b3f9d53c054cc9cd794108d9df6b02ff570.tar.gz
gnu: seabios: Update to 1.12.1.
This is a stable release despite the missing tarball. <https://mail.coreboot.org/hyperkitty/list/seabios@seabios.org/thread/ONGRJVF3A45SAXOKBED52V2UD3YUWTRT/> * gnu/packages/firmware.scm (seabios): Update to 1.12.1. [source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 4df4b22843..90cb8845cf 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -186,19 +186,21 @@ by the b43-open driver of Linux-libre.")
(define-public seabios
(package
(name "seabios")
- (version "1.12.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.seabios.org/downloads/"
- "seabios-" version ".tar.gz"))
- (sha256
- (base32
- "0jx7pnsc2s4a7wbvvwqig6x8wmkw7f2sz0pbgj4jfp77cpjvh5yz"))))
+ (version "1.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/seabios.git")
+ (commit (string-append "rel-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g9y03r5ky58q2g9rhbwfhs42z0zb9f59wfxpwh6zjqa6fyv1r80"))))
(build-system gnu-build-system)
(native-inputs
`(("python-2" ,python-2)))
(arguments
- `(#:tests? #f ; No check target.
+ `(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(replace 'configure