summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-11-17 11:23:31 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-10 15:32:45 +0100
commit6cb805dcceeaa82a229c95d84f55b80e0f07a01f (patch)
tree5406ea8a3c98324ba6d82f0f07c6e51dd20c829e /gnu/packages/firmware.scm
parent6a887e4909d4973c942d8cd62cd11a5c1070c254 (diff)
downloadguix-patches-6cb805dcceeaa82a229c95d84f55b80e0f07a01f.tar
guix-patches-6cb805dcceeaa82a229c95d84f55b80e0f07a01f.tar.gz
gnu: Add eg25-manager.
* gnu/packages/firmware.scm (eg25-manager): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index aefc0a8b69..3ce4b0306e 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,18 +31,24 @@
#:use-module (guix utils)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages assembly)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages cmake)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages flex)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages pkg-config))
(define-public ath9k-htc-firmware
(package
@@ -190,6 +197,33 @@ Broadcom/AirForce chipset BCM43xx with Wireless-Core Revision 5. It is used
by the b43-open driver of Linux-libre.")
(license license:gpl2)))
+(define-public eg25-manager
+ (package
+ (name "eg25-manager")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mobian1/devices/eg25-manager")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h4c4ndcnh88jn65h1kycxkjrydwwwh3irkxvpaxb6ry4wpc45r0"))))
+ (build-system meson-build-system)
+ (native-inputs `(("curl" ,curl)
+ ("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("libgpiod" ,libgpiod)
+ ("libgudev" ,libgudev)
+ ("libusb" ,libusb)))
+ (synopsis "Manager daemon for the Quectel EG25 mobile broadband modem")
+ (description
+ "This package provides a manager daemon for the Quectel EG25 mobile
+broadband modem as found, for example, on PinePhone.")
+ (home-page "https://gitlab.com/mobian1/devices/eg25-manager")
+ (license license:gpl3+)))
+
(define* (make-opensbi-package platform name #:optional (arch "riscv64"))
(package
(name name)