summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-03-06 11:26:35 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:55 +0200
commit283fb648514b68c07203a388fc04cbd2ba7cd3a4 (patch)
treef096ab035420c2031c4f52feed6f7852bee36c90 /gnu/packages/firmware.scm
parentbc5ae287b75ea76ce4dfef2867ddb3dbf30735e5 (diff)
downloadguix-patches-283fb648514b68c07203a388fc04cbd2ba7cd3a4.tar
guix-patches-283fb648514b68c07203a388fc04cbd2ba7cd3a4.tar.gz
gnu: ath9k-htc-firmware: Fix cross compilation.
* gnu/packages/firmware.scm (ath9k-htc-firmware)[phases]: Search for "cross-gcc" in native-inputs and inputs in "configure" phase.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index c473ccd920..3104d78b39 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,7 +60,7 @@
'(#:phases
(modify-phases %standard-phases
(add-before 'configure 'pre-configure
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
(chdir "target_firmware")
;; 'configure' is a simple script that runs 'cmake' with
@@ -67,7 +68,7 @@
(substitute* "configure"
(("^TOOLCHAIN=.*$")
(string-append "TOOLCHAIN="
- (assoc-ref inputs "cross-gcc")
+ (assoc-ref (or native-inputs inputs) "cross-gcc")
"\n")))
#t))
(replace 'install