summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-07-08 15:51:33 -0400
committerCarl Dong <contact@carldong.me>2019-07-08 16:22:01 -0400
commitbcfc54fff80ef6a11fc53c61db333a8065bbfeef (patch)
treeb229b469c4a70c48bb76810f4e9bd8e506f9dbfd /gnu/packages/finance.scm
parent883fe9bb913ac284c6ec203b41fc22cb6212c337 (diff)
downloadguix-patches-bcfc54fff80ef6a11fc53c61db333a8065bbfeef.tar
guix-patches-bcfc54fff80ef6a11fc53c61db333a8065bbfeef.tar.gz
gnu: Update to 0.18.0.
* gnu/packages/finance.scm (bitcoin-core): Update to 0.18.0. [inputs]: Use bdb-4.8 for compatibility. [arguments]: Remove --with-incompatible-bdb from configure flags and add check-functional phase for functional tests.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 550354b650..972b4973d0 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -78,7 +78,7 @@
(define-public bitcoin-core
(package
(name "bitcoin-core")
- (version "0.17.1")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri
@@ -86,7 +86,7 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "0am4pnaf2cisv172jqx6jdpzx770agm8777163lkjbw3ryslymiy"))))
+ "0ps0vw9iknz1b1sx74rabd1yhlxvwbd0aimjzn9hlqkvw286hkjy"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -94,7 +94,7 @@
("util-linux" ,util-linux) ; provides the hexdump command for tests
("qttools" ,qttools)))
(inputs
- `(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
+ `(("bdb" ,bdb-4.8) ; Bitcoin Core requires bdb 4.8 for compatibility
("boost" ,boost)
("libevent" ,libevent)
("miniupnpc" ,miniupnpc)
@@ -104,8 +104,6 @@
(arguments
`(#:configure-flags
(list
- ;; We use a bdb version newer than 4.8.
- "--with-incompatible-bdb"
;; Boost is not found unless specified manually.
(string-append "--with-boost="
(assoc-ref %build-inputs "boost"))
@@ -128,6 +126,11 @@
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR")) ; Tests write to $HOME.
+ #t))
+ (add-after 'check 'check-functional
+ (lambda _
+ (invoke "python3" "./test/functional/test_runner.py"
+ (string-append "--jobs=" (number->string (parallel-job-count))))
#t)))))
(home-page "https://bitcoin.org/en/")
(synopsis "Bitcoin peer-to-peer client")