summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-12-08 13:21:10 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-08 13:31:37 +0100
commitac53cbb368fef080a3e0656794109621bbe036db (patch)
tree46b3e12bdb79daf29983b88cbb4357ac633eeb47 /gnu/packages/finance.scm
parent3ccf33bbe6c36b14385286dbfe6fd1be26d69e7f (diff)
downloadguix-patches-ac53cbb368fef080a3e0656794109621bbe036db.tar
guix-patches-ac53cbb368fef080a3e0656794109621bbe036db.tar.gz
gnu: monero: Improve check phase.
* gnu/packages/finance.scm (monero)[arguments]: Take 'tests?' parameter into consideration in 'check' phase.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f28fbf8809..1f4dd25f6f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -716,12 +716,13 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
#t))
;; Only try tests that don't need access to network or system
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
;; Core tests sometimes fail, at least on i686-linux.
;; Let's disable them for now and just try hash tests
;; and unit tests.
;; (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
- (invoke "make" "ARGS=-R 'hash' --verbose" "test")))
+ (when tests?
+ (invoke "make" "ARGS=-R 'hash' --verbose" "test"))))
(add-after 'check 'unit-tests
(lambda _
(let ((excluded-unit-tests