summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/finance.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm73
1 files changed, 54 insertions, 19 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f5f3713c69..3c3977b656 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -211,7 +211,7 @@ line client and a client based on Qt.")
(define-public hledger
(package
(name "hledger")
- (version "1.14.2")
+ (version "1.21")
(source
(origin
(method url-fetch)
@@ -221,7 +221,7 @@ line client and a client based on Qt.")
".tar.gz"))
(sha256
(base32
- "1si9zqparkdq77yji87lhcsrf11fr3gisqwsv82cabhrhc36x6l4"))))
+ "07fcfkmv4cy92njnf2qc7jh0naz96q962hxldcd7hk4k7ddv0mss"))))
(build-system haskell-build-system)
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
@@ -230,17 +230,18 @@ line client and a client based on Qt.")
("ghc-data-default" ,ghc-data-default)
("ghc-decimal" ,ghc-decimal)
("ghc-diff" ,ghc-diff)
- ("ghc-easytest" ,ghc-easytest)
("ghc-hashable" ,ghc-hashable)
("ghc-hledger-lib" ,ghc-hledger-lib)
("ghc-lucid" ,ghc-lucid)
("ghc-math-functions" ,ghc-math-functions)
("ghc-megaparsec" ,ghc-megaparsec)
- ("ghc-mtl-compat" ,ghc-mtl-compat)
("ghc-old-time" ,ghc-old-time)
- ("ghc-pretty-show" ,ghc-pretty-show)
("ghc-regex-tdfa" ,ghc-regex-tdfa)
("ghc-safe" ,ghc-safe)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-extra" ,ghc-extra)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-timeit" ,ghc-timeit)
("ghc-shakespeare" ,ghc-shakespeare)
("ghc-split" ,ghc-split)
("ghc-tabular" ,ghc-tabular)
@@ -249,9 +250,6 @@ line client and a client based on Qt.")
("ghc-utf8-string" ,ghc-utf8-string)
("ghc-utility-ht" ,ghc-utility-ht)
("ghc-wizards" ,ghc-wizards)))
- (native-inputs
- `(("ghc-test-framework" ,ghc-test-framework)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
(home-page "https://hledger.org")
(synopsis "Command-line interface for the hledger accounting system")
(description
@@ -894,6 +892,33 @@ the Monero GUI client.")
Ledger Nano as a hardware SSH/GPG agent.")
(license license:lgpl3)))
+(define-public trezor-gpg-pinentry-tk
+ (package
+ (name "trezor-gpg-pinentry-tk")
+ (version "0.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rendaw/trezor-gpg-pinentry-tk/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mblx4favmw4nf7k9rfl00ivv77kgdiwghyz4xv5cp0v410kjaqc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; No test suite.
+ (inputs
+ `(("python-tkinter" ,python "tk")))
+ (home-page "https://github.com/rendaw/trezor-gpg-pinentry-tk")
+ (synopsis "GPG pinentry program for use with @code{trezor-agent}")
+ (description
+ "This package provides a GPG pinentry program for use with
+@code{trezor-agent}, or for people with number-only PINs. It displays
+a grid of unlabeled buttons and supports configurable keyboard
+settings.")
+ (license license:bsd-2)))
+
(define-public python-mnemonic
(package
(name "python-mnemonic")
@@ -1676,7 +1701,7 @@ generate a variety of reports from them, and provides a web interface.")
(define-public hledger-web
(package
(name "hledger-web")
- (version "1.14.1")
+ (version "1.21")
(source
(origin
(method url-fetch)
@@ -1684,38 +1709,48 @@ generate a variety of reports from them, and provides a web interface.")
"hledger-web/hledger-web-" version ".tar.gz"))
(sha256
(base32
- "0w59nr7mj0nx8z44cvhy1rhlj5rmx0wq4p5nfl4dycfmp7jwvsm1"))))
+ "0ivszqcypw0j2wn4r7fv7dqm1pvr0b1y6rqpxagzyk8cxn3ic9g2"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f ; TODO: fail.
+ #:cabal-revision
+ ("1" "1hnw10ibhbafbsfj5lzlxwjg4cjnqr5bb51n6mqbi30qqabgq78x")))
(inputs
- `(("ghc-decimal" ,ghc-decimal)
- ("ghc-aeson" ,ghc-aeson)
+ `(("ghc-aeson" ,ghc-aeson)
("ghc-blaze-html" ,ghc-blaze-html)
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-case-insensitive" ,ghc-case-insensitive)
("ghc-clientsession" ,ghc-clientsession)
("ghc-cmdargs" ,ghc-cmdargs)
- ("ghc-conduit" ,ghc-conduit)
("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-conduit" ,ghc-conduit)
("ghc-data-default" ,ghc-data-default)
+ ("ghc-decimal" ,ghc-decimal)
+ ("ghc-extra" ,ghc-extra)
("ghc-hjsmin" ,ghc-hjsmin)
- ("hledger" ,hledger)
("ghc-hledger-lib" ,ghc-hledger-lib)
+ ("ghc-hspec" ,ghc-hspec)
("ghc-http-client" ,ghc-http-client)
("ghc-http-conduit" ,ghc-http-conduit)
("ghc-http-types" ,ghc-http-types)
- ("ghc-json" ,ghc-json)
("ghc-megaparsec" ,ghc-megaparsec)
- ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-network" ,ghc-network)
("ghc-shakespeare" ,ghc-shakespeare)
- ("ghc-wai" ,ghc-wai)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-wai-cors" ,ghc-wai-cors)
("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-wai" ,ghc-wai)
("ghc-wai-handler-launch" ,ghc-wai-handler-launch)
("ghc-warp" ,ghc-warp)
("ghc-yaml" ,ghc-yaml)
- ("ghc-yesod" ,ghc-yesod)
("ghc-yesod-core" ,ghc-yesod-core)
("ghc-yesod-form" ,ghc-yesod-form)
- ("ghc-yesod-static" ,ghc-yesod-static)))
+ ("ghc-yesod" ,ghc-yesod)
+ ("ghc-yesod-static" ,ghc-yesod-static)
+ ("ghc-yesod-test" ,ghc-yesod-test)
+ ("hledger" ,hledger)))
(home-page "https://hledger.org")
(synopsis "Web-based user interface for the hledger accounting system")
(description "This package provides a simple Web-based User