summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-30 14:32:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-30 14:32:53 +0100
commit998e6cdcd2a9fcce18b46676ce47990867227945 (patch)
tree5b6b08860183d164108257a3715e0c5673063f5a /gnu/packages/finance.scm
parenta557810ac72effd6841b76772195b10c03dee345 (diff)
parentd8bb1097d764949e80f9e41d26b3b194163dd716 (diff)
downloadguix-patches-998e6cdcd2a9fcce18b46676ce47990867227945.tar
guix-patches-998e6cdcd2a9fcce18b46676ce47990867227945.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1230e5c270..68bd2f97c5 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -87,7 +87,7 @@
(define-public bitcoin-core
(package
(name "bitcoin-core")
- (version "0.18.0")
+ (version "0.18.1")
(source (origin
(method url-fetch)
(uri
@@ -95,15 +95,15 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "0ps0vw9iknz1b1sx74rabd1yhlxvwbd0aimjzn9hlqkvw286hkjy"))))
+ "15mz0gmm058gmq2gdpffbw25jpv7mksyhyfws6i7mqvrapqr6zaw"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python) ; for the tests
- ("util-linux" ,util-linux) ; provides the hexdump command for tests
+ ("python" ,python) ; for the tests
+ ("util-linux" ,util-linux) ; provides the hexdump command for tests
("qttools" ,qttools)))
(inputs
- `(("bdb" ,bdb-4.8) ; Bitcoin Core requires bdb 4.8 for compatibility
+ `(("bdb" ,bdb-4.8) ; 4.8 required for compatibility
("boost" ,boost)
("libevent" ,libevent)
("miniupnpc" ,miniupnpc)
@@ -134,7 +134,7 @@
#t))
(add-before 'check 'set-home
(lambda _
- (setenv "HOME" (getenv "TMPDIR")) ; Tests write to $HOME.
+ (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
#t))
(add-after 'check 'check-functional
(lambda _