summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-08-14 15:01:38 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2021-08-14 15:05:12 +0200
commit98b47af0ad69cb5c29c84c6c27bd1b37fa3cfdb0 (patch)
tree5e3200afe1f33a5ad17ff364a302d04cc12c2ad9 /gnu/packages/finance.scm
parentc0e782f0dad914109f04f2554b9842ff1f51ee1b (diff)
downloadguix-patches-98b47af0ad69cb5c29c84c6c27bd1b37fa3cfdb0.tar
guix-patches-98b47af0ad69cb5c29c84c6c27bd1b37fa3cfdb0.tar.gz
gnu: Add python-btchip-python.
* gnu/packages/finance.scm (python-btchip-python): New variable.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 430552c3a3..807f2c1074 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -936,6 +936,30 @@ Ledger Blue/Nano S.")
(define-public python2-ledgerblue
(package-with-python2 python-ledgerblue))
+(define-public python-btchip-python
+ (package
+ (name "python-btchip-python")
+ (version "0.1.32")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "btchip-python" version))
+ (sha256
+ (base32
+ "0mcg3gfd0qk8lhral3vy9cfd4pii9kzs42q71pf6b3y0c70y1x9l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; those require PyQt4
+ (propagated-inputs
+ `(("python-ecdsa" ,python-ecdsa)
+ ("python-hidapi" ,python-hidapi)))
+ (home-page "https://github.com/LedgerHQ/btchip-python")
+ (synopsis "Python library to communicate with Ledger Nano dongle")
+ (description
+ "This package provides a Python library to communicate with Ledger
+Nano dongle.")
+ (license license:asl2.0)))
+
(define-public python-trezor
(package
(name "python-trezor")