summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 03:18:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:36:51 +0200
commit8ee3e4d9e9cd991ece0cb591ff10c223aa154866 (patch)
treee34ad8c0c1b370f26d4d75e6236a9d7fd4f0e1b2 /gnu/packages/finance.scm
parent598afe95c3e4bc79c168cff2c65bd45fb94dc0c1 (diff)
downloadguix-patches-8ee3e4d9e9cd991ece0cb591ff10c223aa154866.tar
guix-patches-8ee3e4d9e9cd991ece0cb591ff10c223aa154866.tar.gz
gnu: electrum: Return #t from phases.
* gnu/packages/finance.scm (electrum)[arguments]: Return truth from ‘patch-home’.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 881b38d4c1..3f58999e4b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -455,14 +455,15 @@ do so.")
("python-dnspython" ,python-dnspython)
("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
(arguments
- `(#:tests? #f ;; package doesn't have any tests
+ `(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(add-before 'build 'patch-home
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "setup.py"
(("~/.local/share")
- (string-append (assoc-ref outputs "out") "/local/share"))))))))
+ (string-append (assoc-ref outputs "out") "/local/share")))
+ #t)))))
(home-page "https://electrum.org/")
(synopsis "Bitcoin wallet")
(description