summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:14 +0200
commit8a2a5ad6961082e3fd8e5ba4608164c34827c88e (patch)
tree8e057a9a98f5a63a7b4f925db136cdb3f1e7b09f /gnu/packages/finance.scm
parent90f5020c681ba522a9603e4c430f33f09d55d0cb (diff)
downloadguix-patches-8a2a5ad6961082e3fd8e5ba4608164c34827c88e.tar
guix-patches-8a2a5ad6961082e3fd8e5ba4608164c34827c88e.tar.gz
gnu: electrum: Update to 4.0.9.
* gnu/packages/finance.scm (electrum): Update to 4.0.9. [inputs]: Remove python-pyaes, python-pysocks, python-sip, python-pbkdf2, python-requests, python-jsonrpclib-pelix and python-ecdsa, python-dnspython-1.16. Add python-dnspython, python-bitstring, python-attrs, python-cryptography, python-qdarkstyle and libsecp256k1. [arguments]: Copy 'use-libsecp256k1-input phase from (electron-cash) to #:phases to fix runtime lookup of libsecp256k1 library. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm29
1 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c7a606f3b2..b6921d343f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -495,7 +495,7 @@ do so.")
(define-public electrum
(package
(name "electrum")
- (version "3.3.8")
+ (version "4.0.9")
(source
(origin
(method url-fetch)
@@ -503,7 +503,7 @@ do so.")
version "/Electrum-"
version ".tar.gz"))
(sha256
- (base32 "1g00cj1pmckd4xis8r032wmraiv3vd3zc803hnyxa2bnhj8z3bg2"))
+ (base32 "1fvjiagi78f32nxgr2rx8jas8hxfvpp1c8fpfcalvykmlhdc2gva"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -512,21 +512,19 @@ do so.")
#t))))
(build-system python-build-system)
(inputs
- `(("python-pyaes" ,python-pyaes)
- ("python-pysocks" ,python-pysocks)
- ("python-sip" ,python-sip)
- ("python-pyqt" ,python-pyqt)
- ("python-ecdsa" ,python-ecdsa)
- ("python-pbkdf2" ,python-pbkdf2)
- ("python-requests" ,python-requests)
+ `(("python-pyqt" ,python-pyqt)
("python-qrcode" ,python-qrcode)
("python-protobuf" ,python-protobuf)
("python-aiohttp" ,python-aiohttp)
("python-aiohttp-socks" ,python-aiohttp-socks)
("python-aiorpcx" ,python-aiorpcx)
("python-certifi" ,python-certifi)
- ("python-dnspython" ,python-dnspython-1.16)
- ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
+ ("python-bitstring" ,python-bitstring)
+ ("python-attrs" ,python-attrs)
+ ("python-cryptography" ,python-cryptography)
+ ("python-qdarkstyle" ,python-qdarkstyle)
+ ("python-dnspython" ,python-dnspython)
+ ("libsecp256k1" ,libsecp256k1)))
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -540,7 +538,14 @@ do so.")
(substitute* "setup.py"
(("sys\\.prefix")
(format #f "\"~a\"" out)))
- #t))))))
+ #t)))
+ (add-after 'unpack 'use-libsecp256k1-input
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "electrum/ecc_fast.py"
+ (("library_paths = .* 'libsecp256k1.so.0'.")
+ (string-append "library_paths = ('"
+ (assoc-ref inputs "libsecp256k1")
+ "/lib/libsecp256k1.so.0'"))))))))
(home-page "https://electrum.org/")
(synopsis "Bitcoin wallet")
(description