summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
committerMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
commit893c2df00daa4e6dd6a7ff3813d7df5329877f9e (patch)
treeacd0db459464acae47083b66d5ce12cc656e2f10 /gnu/packages/finance.scm
parent04b9b7bb05aff4c41f46cd79aa7bc953ace16e86 (diff)
parent0ccc9a0f5bb89b239d56157ea66f8420fcec5ba6 (diff)
downloadguix-patches-893c2df00daa4e6dd6a7ff3813d7df5329877f9e.tar
guix-patches-893c2df00daa4e6dd6a7ff3813d7df5329877f9e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm42
1 files changed, 35 insertions, 7 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 87775c68fe..e8c4e6bc9d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -448,7 +448,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.14.1.0")
+ (version "0.14.1.2")
(source
(origin
(method git-fetch)
@@ -469,7 +469,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
#t))
(sha256
(base32
- "1asa197fad81jfv12qgaa7y7pdr1r1pda96m9pvivkh4v30cx0nh"))))
+ "00zl883c7lcd9z7g4y3vv7rxmr7ppzrxdblnhk32r9l3qzyw55r6"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -511,6 +511,11 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
(("return \\(")
"return ((std::string(getenv(\"HOME\"))) / "))
#t))
+ (add-after 'change-log-path 'fix-file-permissions-for-tests
+ (lambda _
+ (for-each make-file-writable
+ (find-files "tests/data/" "wallet_9svHk1.*"))
+ #t))
;; Only try tests that don't need access to network or system
(replace 'check
(lambda _
@@ -525,11 +530,6 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
"DNSResolver.DNSSECSuccess"
"DNSResolver.DNSSECFailure"
"DNSResolver.GetTXTRecord"
- ;; TODO: Find why portability_wallet test fails
- ;; Maybe the Boost version used to create the test
- ;; wallet and the current Boost version are not
- ;; completely compatible?
- "Serialization.portability_wallet"
"is_hdd.linux_os_root")
":")))
(invoke "tests/unit_tests/unit_tests"
@@ -1114,3 +1114,31 @@ information.")
(description "This allows a Trezor hardware wallet to communicate to the
Trezor wallet.")
(license license:lgpl3+)))
+
+(define-public bitcoin-abc
+ (package
+ (inherit bitcoin-core)
+ (name "bitcoin-abc")
+ (version "0.19.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.bitcoinabc.org/"
+ version "/linux/src/bitcoin-abc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ (home-page "https://www.bitcoinabc.org/")
+ (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+ (description
+ "Bitcoin Cash brings sound money to the world, fulfilling the original
+promise of Bitcoin as Peer-to-Peer Electronic Cash. Merchants and users are
+empowered with low fees and reliable confirmations is a digital currency that
+enables instant payments to anyone anywhere in the world. It uses
+peer-to-peer technology to operate without central authority: managing
+transactions and issuing money are carried out collectively by the network.
+As a fork it implemented changes lowering the time between blocks and now
+offers confimations after less than 5 seconds and have significantly lower
+fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
+Cash protocol. This package provides the Bitcoin Cash command line client and
+a client based on Qt. This is a fork of Bitcoin Core.")))