summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-13 22:50:36 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-18 10:51:05 +0200
commit84759b7c20fa4ee7e8004f2fc0ddec694cf9aedd (patch)
tree4a706907edb61ade90c2995eae1fb1c0908c4b26 /gnu/packages/finance.scm
parentb4659234358c35f8e92b51d5ed23f051a931a2a3 (diff)
downloadguix-patches-84759b7c20fa4ee7e8004f2fc0ddec694cf9aedd.tar
guix-patches-84759b7c20fa4ee7e8004f2fc0ddec694cf9aedd.tar.gz
gnu: Add ta-lib.
* gnu/packages/finance.scm (ta-lib): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 5e243d0452..7ccf4b77b6 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 ZmnSCPxj jxPCSnmZ <ZmnSCPxj@protonmail.com>
;;; Copyright © 2021 François J <francois-oss@avalenn.eu>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1753,3 +1754,29 @@ Interface (UI) for the hledger accounting system. It can be used as a
local, single-user UI, or as a multi-user UI for viewing, adding, and
editing on the Web.")
(license license:gpl3)))
+
+(define-public ta-lib
+ (package
+ (name "ta-lib")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ta-lib/ta-lib/"
+ version "/ta-lib-" version "-src.tar.gz"))
+ (sha256
+ (base32 "0lf69nna0aahwpgd9m9yjzbv2fbfn081djfznssa84f0n7y1xx4z"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Parallel build fails with:
+ ;; mv -f .deps/gen_code-gen_code.Tpo .deps/gen_code-gen_code.Po
+ ;; mv: cannot stat '.deps/gen_code-gen_code.Tpo': No such file or directory
+ ;; Makefile:254: recipe for target 'gen_code-gen_code.o' failed
+ #:parallel-build? #f
+ #:configure-flags '("--disable-static")))
+ (home-page "https://ta-lib.org")
+ (synopsis "Technical analysis library")
+ (description
+ "TA-Lib is a library providing common functions for the technical
+analysis of financial market data.")
+ (license license:bsd-3)))