summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-04-16 11:49:48 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-16 11:49:48 +0200
commit7eb9176a6e5b116bc244a08ddd72d15cfeeb3ba0 (patch)
tree7960d3e801146eb571207a0c8e14df4e399a43f7 /gnu/packages/finance.scm
parent4bd3fdda63c45bdaf38dfdb5fba64a3ed2ce63dd (diff)
downloadguix-patches-7eb9176a6e5b116bc244a08ddd72d15cfeeb3ba0.tar
guix-patches-7eb9176a6e5b116bc244a08ddd72d15cfeeb3ba0.tar.gz
gnu: bitcoin-unlimited: Update to 1.10.0.0.
* gnu/packages/finance.scm (bitcoin-unlimited): Update to 1.10.0.0. [arguments]: Update 'fix-tests' phase.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9d8f7e3b15..84547639e4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1524,7 +1524,7 @@ following three utilities are included with the library:
(define-public bitcoin-unlimited
(package
(name "bitcoin-unlimited")
- (version "1.9.2.0")
+ (version "1.10.0.0")
(source
(origin
(method git-fetch)
@@ -1533,7 +1533,7 @@ following three utilities are included with the library:
(commit (string-append "BCHunlimited" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cmrvh7azz0g89rsx6i8apd1li6r1lb3jrmbbf8fic1918lwv62m"))))
+ (base32 "12yb2rbd6hsns43qyxc5dm7h5k4sph9sb64q7kkbqi3xhgrrsjdq"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -1574,30 +1574,17 @@ following three utilities are included with the library:
(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
(lambda _
- ;; Fix data specific test failure
- ;; https://reviews.bitcoinabc.org/rABC67bbd3d0aaee2952ff1cb5da51d1fd0b50c2b63a
- (substitute* "src/test/rpc_tests.cpp"
- (("1607731200") "9907731200"))
-
;; Disable utilprocess_tests because it never ends.
;; It looks like it tries to start /bin/sleep and waits until it
;; is in the list of running processes, but /bin/sleep doesn't
;; exist.
(substitute* "src/Makefile.test.include"
(("test/utilprocess_tests.cpp")
- ""))
-
- ;; Some transaction validation rules have changed (see upstream
- ;; commit f208400825d4641b9310a1fba023d56e0862e3b0), which makes
- ;; a test fail. Disable it for now.
- ;; TODO: Remove this when the next version is released.
- (substitute* "src/Makefile.test.include"
- (("test/txvalidationcache_tests.cpp")
""))))
(add-before 'check 'set-home
(lambda _
- (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
- #t)))))
+ ;; Tests write to $HOME
+ (setenv "HOME" (getenv "TMPDIR")))))))
(home-page "https://www.bitcoinunlimited.info/")
(synopsis "Client for the Bitcoin Cash protocol")
(description