summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorChristine Lemmer-Webber <cwebber@dustycloud.org>2021-09-29 12:46:01 -0400
committerChristine Lemmer-Webber <cwebber@dustycloud.org>2021-10-12 23:34:03 -0400
commit37832406bef8e9b61b1c3b533988d5a873cb9a21 (patch)
tree7bae238635e025ef5067afdb36235905c4080218 /gnu/packages/finance.scm
parentda86a80068b797c3dc4df83a7db5a15959fff685 (diff)
downloadguix-patches-37832406bef8e9b61b1c3b533988d5a873cb9a21.tar
guix-patches-37832406bef8e9b61b1c3b533988d5a873cb9a21.tar.gz
gnu: emacs-beancount: Restructure package, now independent of beancount.
* gnu/packages/finance.scm (emacs-beancount): Restructure package, now independent of beancount and in its own git repository. Note that there is no version number for the now independent code tree, so unfortunately this might look like a "version downgrade" to some users as it switched from being beancount's revision number to being a git-derived version number.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm41
1 files changed, 23 insertions, 18 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 557a19e677..5e243d0452 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1668,25 +1668,30 @@ define financial transaction records in a text file, read them in memory,
generate a variety of reports from them, and provides a web interface.")
(license license:gpl2)))
-;; The beancount source ships with elisp in a subdirectory
(define-public emacs-beancount
- (package
- (inherit beancount)
- (name "emacs-beancount")
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'chdir-emacs
- (lambda _
- (chdir "editors/emacs")
- #t)))))
- (inputs '())
- (native-inputs '())
- (synopsis "Emacs mode for beancount")
- (description
- "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")))
+ ;; Note that upstream has not made any release since this project moved
+ ;; into its own repository (it was originally part of beancount itself)
+ (let ((commit "dbafe6a73d90c1f64d457b356b9dbb43499f70d5")
+ (revision "0"))
+ (package
+ (name "emacs-beancount")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beancount/beancount-mode")
+ (commit commit)))
+ (sha256
+ (base32
+ "0v9bws2gv5b00x829p7hrcxqgdp7iwxvv1vhfjka81qrw6w1fvjw"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/beancount/beancount-mode")
+ (synopsis "Emacs mode for Beancount")
+ (description
+ "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")
+ (license license:gpl3+))))
(define-public hledger-web
(package