summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2020-11-02 11:15:06 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-02 14:59:35 +0100
commit31b97a089d25ae2b8f70d19a138731de5ae88c67 (patch)
tree0b4dd21d58df158d43d33944f47a13f5df34b755 /gnu/packages/finance.scm
parent89a4eb38c9b20b66856b53fe68e8ce8baf26ad0d (diff)
downloadguix-patches-31b97a089d25ae2b8f70d19a138731de5ae88c67.tar
guix-patches-31b97a089d25ae2b8f70d19a138731de5ae88c67.tar.gz
gnu: emacs-ledger-mode: Update to 4.0.0.
* gnu/packages/finance.scm (emacs-ledger-mode): Update to 4.0.0. [arguments]<#:tests?>: Remove argument. [phases] check: Replace with working check phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm124
1 files changed, 62 insertions, 62 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c0b6400cc7..ffbf3b218d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -355,67 +355,67 @@ in ability, and easy to use.")
"See src/wcwidth.cc in the distribution.")))))
(define-public emacs-ledger-mode
- ;; There have been no new releases since 2016.
- (let ((commit "253a20dc62e137ed0ed8e1dd8614ecba116610ea")
- (revision "1"))
- (package
- (name "emacs-ledger-mode")
- (version (git-version "3.1.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ledger/ledger-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06wrgkqpgvk17vibrk2qikdlqn8y63jg86marp1wgmram92mb3jk"))))
- (build-system cmake-build-system)
- (arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build emacs-utils))
- #:tests? #f ; there are none
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-site-dir
- (lambda _
- (substitute* "CMakeLists.txt"
- (("DESTINATION share/emacs/site-lisp/ledger-mode")
- "DESTINATION share/emacs/site-lisp"))
- #t))
- (add-before 'build 'patch-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((ledger (assoc-ref inputs "ledger")))
- (make-file-writable "ledger-exec.el")
- (emacs-substitute-variables "ledger-exec.el"
- ("ledger-binary-path" (string-append ledger "/bin/ledger"))))
- #t))
- (add-after 'build 'build-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((target (string-append (assoc-ref outputs "out")
- "/share/info")))
- (mkdir-p target)
- (invoke "makeinfo" "-o" target
- "../source/doc/ledger-mode.texi"))
- #t))
- (add-after 'install 'generate-autoload
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((site-dir (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp")))
- (emacs-generate-autoloads ,name site-dir))
- #t)))))
- (inputs
- `(("ledger" ,ledger)))
- (native-inputs
- `(("emacs-minimal" ,emacs-minimal)
- ("texinfo" ,texinfo)))
- (home-page "https://ledger-cli.org/")
- (synopsis "Command-line double-entry accounting program")
- (description
- "Ledger is a powerful, double-entry accounting system that is
+ (package
+ (name "emacs-ledger-mode")
+ (version "4.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ledger/ledger-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1r5rcyxd6d1rqwamzpvqdbkbdf1zbj75aaciqijrklnm59ps244y"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:modules ((guix build cmake-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build emacs-utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-site-dir
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION share/emacs/site-lisp/ledger-mode")
+ "DESTINATION share/emacs/site-lisp"))
+ #t))
+ (add-before 'build 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ledger (assoc-ref inputs "ledger")))
+ (make-file-writable "ledger-exec.el")
+ (emacs-substitute-variables "ledger-exec.el"
+ ("ledger-binary-path" (string-append ledger "/bin/ledger"))))
+ #t))
+ (add-after 'build 'build-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/share/info")))
+ (mkdir-p target)
+ (invoke "makeinfo" "-o" target
+ "../source/doc/ledger-mode.texi"))
+ #t))
+ (add-after 'install 'generate-autoload
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((site-dir (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp")))
+ (emacs-generate-autoloads ,name site-dir))
+ #t))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "../source/test"
+ (invoke "make" "test-batch")))))))
+ (inputs
+ `(("ledger" ,ledger)))
+ (native-inputs
+ `(("emacs-minimal" ,emacs-minimal)
+ ("texinfo" ,texinfo)))
+ (home-page "https://ledger-cli.org/")
+ (synopsis "Command-line double-entry accounting program")
+ (description
+ "Ledger is a powerful, double-entry accounting system that is
accessed from the UNIX command-line. This may put off some users, since
there is no flashy UI, but for those who want unparalleled reporting
access to their data there are few alternatives.
@@ -429,7 +429,7 @@ a graph or html instead. Ledger is simple in concept, surprisingly rich
in ability, and easy to use.
This package provides the Emacs mode.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public geierlein
(package