summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 23:58:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 23:58:58 +0100
commit1219a7cc0521e4916287acd265e50b0af2bfb336 (patch)
tree05263ce5e72b5ce125fb32e127aec36818802aab /gnu/packages/finance.scm
parent447b61d4cfb2a2de39221777590233eeae3aed12 (diff)
downloadguix-patches-1219a7cc0521e4916287acd265e50b0af2bfb336.tar
guix-patches-1219a7cc0521e4916287acd265e50b0af2bfb336.tar.gz
gnu: bitcoin-core: Update to 0.18.1.
* gnu/packages/finance.scm (bitcoin-core): Update to 0.18.1.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 960e3adeb3..bbd1aa947c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -86,7 +86,7 @@
(define-public bitcoin-core
(package
(name "bitcoin-core")
- (version "0.18.0")
+ (version "0.18.1")
(source (origin
(method url-fetch)
(uri
@@ -94,15 +94,15 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "0ps0vw9iknz1b1sx74rabd1yhlxvwbd0aimjzn9hlqkvw286hkjy"))))
+ "15mz0gmm058gmq2gdpffbw25jpv7mksyhyfws6i7mqvrapqr6zaw"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python) ; for the tests
- ("util-linux" ,util-linux) ; provides the hexdump command for tests
+ ("python" ,python) ; for the tests
+ ("util-linux" ,util-linux) ; provides the hexdump command for tests
("qttools" ,qttools)))
(inputs
- `(("bdb" ,bdb-4.8) ; Bitcoin Core requires bdb 4.8 for compatibility
+ `(("bdb" ,bdb-4.8) ; 4.8 required for compatibility
("boost" ,boost)
("libevent" ,libevent)
("miniupnpc" ,miniupnpc)
@@ -133,7 +133,7 @@
#t))
(add-before 'check 'set-home
(lambda _
- (setenv "HOME" (getenv "TMPDIR")) ; Tests write to $HOME.
+ (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
#t))
(add-after 'check 'check-functional
(lambda _