summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-12-03 14:30:53 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-09 18:32:04 +0100
commit054ff198e446ae7b0a0dd183caf69368b8b9f580 (patch)
treec1af84910bdb51de2764a80f97dc6950814c2963 /gnu/packages/finance.scm
parentbf770d92402fbdfe1ea601db1d97bd888571b7e2 (diff)
downloadguix-patches-054ff198e446ae7b0a0dd183caf69368b8b9f580.tar
guix-patches-054ff198e446ae7b0a0dd183caf69368b8b9f580.tar.gz
gnu: bitcoin-abc: Update to 0.20.7.
* gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.7. [native-inputs]: Add autoconf, automake and libtool. [inputs]: Add qrencode and zlib. [arguments]: Remove fix-tests phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1412c7ca95..5588fe00ea 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -43,6 +43,8 @@
#:use-module (guix build-system go)
#:use-module (guix utils)
#:use-module (gnu packages)
+ #:use-module (gnu packages aidc)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -1172,7 +1174,7 @@ Trezor wallet.")
(package
(inherit bitcoin-core)
(name "bitcoin-abc")
- (version "0.20.4")
+ (version "0.20.7")
(source (origin
(method url-fetch)
(uri (string-append "https://download.bitcoinabc.org/"
@@ -1180,7 +1182,15 @@ Trezor wallet.")
version ".tar.gz"))
(sha256
(base32
- "0fld54z3l7z7k5n35rrjichjnx37j9xp0rv8i69m3x4qfj1xk2np"))))
+ "0py5ilfi4r8qh5r9637vwch27sqrrn0dg9rz8bccnj3lp2xpzw27"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python) ; for the tests
+ ("util-linux" ,util-linux) ; provides the hexdump command for tests
+ ("qttools" ,qttools)))
(inputs
`(("bdb" ,bdb-5.3)
("boost" ,boost)
@@ -1188,19 +1198,9 @@ Trezor wallet.")
("miniupnpc" ,miniupnpc)
("openssl" ,openssl)
("protobuf" ,protobuf)
- ("qtbase" ,qtbase)))
- (arguments
- (substitute-keyword-arguments (package-arguments bitcoin-core)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'fix-tests
- ;; Disable 'check-devtools' test which tries to run a
- ;; python script that doesn't exist.
- (lambda _
- (substitute* "Makefile.in"
- (("^check-local: check-devtools")
- "check-local:"))
- #t))))))
+ ("qrencode" ,qrencode)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
(home-page "https://www.bitcoinabc.org/")
(synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
(description