summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-08 11:51:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-08 11:51:03 +0200
commitf45e304aa45fada9716048ae9cf67854742e8dc5 (patch)
treee5b8059bffa7d84aadc787fe320da99fbd8b2fa1 /gnu/packages/file-systems.scm
parentddcec589bca1d8538df87ec731990ce7da5831d5 (diff)
downloadguix-patches-f45e304aa45fada9716048ae9cf67854742e8dc5.tar
guix-patches-f45e304aa45fada9716048ae9cf67854742e8dc5.tar.gz
gnu: python-dropbox: Update to 11.25.0.
* gnu/packages/file-systems.scm (python-dropbox): Update to 11.25.0. [propagated-inputs]: Remove python-certifi, python-chardet, and python-urllib3.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 71bc692f30..7cba71f6a4 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1507,26 +1507,22 @@ compatible directories.")
(define-public python-dropbox
(package
(name "python-dropbox")
- (version "11.5.0")
+ (version "11.25.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dropbox" version))
(sha256
- (base32
- "16bxx9xqx2s4d9khrw57a0bj4q7nc6kq355wl4pfddn9cqvh9rg2"))))
+ (base32 "0vq9c2hp2amsxr2ys2mlgqp6a8hxmvrcwav70ri7wjzalfs32gj6"))))
(build-system python-build-system)
(arguments '(#:tests? #f)) ; Tests require a network connection.
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(propagated-inputs
- `(("python-certifi" ,python-certifi)
- ("python-chardet" ,python-chardet)
- ("python-requests" ,python-requests)
+ `(("python-requests" ,python-requests)
("python-six" ,python-six)
- ("python-stone" ,python-stone)
- ("python-urllib3" ,python-urllib3)))
+ ("python-stone" ,python-stone)))
(home-page "https://www.dropbox.com/developers")
(synopsis "Official Dropbox API Client")
(description "This package provides a Python SDK for integrating with the