summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-13 19:49:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-16 11:43:34 +0300
commite0945a02a41afe31d99e3920aa9f7e2239df7bb7 (patch)
treec41f98f69f2897857633a875996d7a604a43d684 /gnu/packages/file-systems.scm
parentcfa7d0cbdc443431f82689ec778448f8f080f8a2 (diff)
downloadguix-patches-e0945a02a41afe31d99e3920aa9f7e2239df7bb7.tar
guix-patches-e0945a02a41afe31d99e3920aa9f7e2239df7bb7.tar.gz
gnu: Add dbxfs.
* gnu/packages/file-systems.scm (dbxfs): New variable. * gnu/packages/patches/dbxfs-remove-sentry-sdk.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 7d06e3e899..b8612ac3b2 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -889,3 +889,33 @@ compatible directories.")
(description "This package provides a Python SDK for integrating with the
Dropbox API v2.")
(license license:expat)))
+
+(define-public dbxfs
+ (package
+ (name "dbxfs")
+ (version "1.0.43")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dbxfs" version))
+ (sha256
+ (base32
+ "1f9sy2ax215dxiwszrrcadffjdsmrlxm4kwrbiap9dhxvzm226ks"))
+ (patches (search-patches "dbxfs-remove-sentry-sdk.patch"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests requires safefs
+ (propagated-inputs
+ `(("python-appdirs" ,python-appdirs)
+ ("python-block-tracing" ,python-block-tracing)
+ ("python-dropbox" ,python-dropbox)
+ ("python-keyring" ,python-keyring)
+ ("python-keyrings.alt" ,python-keyrings.alt)
+ ("python-privy" ,python-privy)
+ ("python-userspacefs" ,python-userspacefs)))
+ (home-page "https://github.com/rianhunter/dbxfs")
+ (synopsis "User-space file system for Dropbox")
+ (description
+ "@code{dbxfs} allows you to mount your Dropbox folder as if it were a
+local filesystem using FUSE.")
+ (license license:gpl3+)))