summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/file-systems.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 788aa0ebea..24d5619c8e 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -415,8 +416,8 @@ from a mounted file system.")
(license license:gpl2+)))
(define-public bcachefs-tools
- (let ((commit "6c42566c6204bb5dcd6af3b97257e548b9d2db67")
- (revision "9"))
+ (let ((commit "37850436dd7dfbe67738749c4d4a2506ffff1ec3")
+ (revision "11"))
(package
(name "bcachefs-tools")
(version (git-version "0.1" revision commit))
@@ -428,7 +429,7 @@ from a mounted file system.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xagz0k3li10ydma55mnld0nb2pyfx90vsdvgjflgnx6jw3cq4dq"))))
+ (base32 "040vgxrimahmfs9rhlggfwg0bzl7h9j2ksx3563rh63asjwlhnhi"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1173,7 +1174,7 @@ with the included @command{xfstests-check} helper.")
(define-public zfs
(package
(name "zfs")
- (version "2.1.0")
+ (version "2.1.1")
(outputs '("out" "module" "src"))
(source
(origin
@@ -1182,7 +1183,7 @@ with the included @command{xfstests-check} helper.")
"/download/zfs-" version
"/zfs-" version ".tar.gz"))
(sha256
- (base32 "0kzkggwznp4m3503f2m4lcinbl99jg50j4asrwfpfk1862vdrgb0"))))
+ (base32 "1zsc0zkz5cci6pxc0kwzn3xg72qv2fq65phb768y5dgk1784hkxx"))))
(build-system linux-module-build-system)
(arguments
`(;; The ZFS kernel module should not be downloaded since the license
@@ -1276,8 +1277,7 @@ with the included @command{xfstests-check} helper.")
(substitute* '("Makefile.am" "Makefile.in")
(("\\$\\(prefix)/src") (string-append src "/src")))
(substitute* (find-files "udev/rules.d/" ".rules.in$")
- (("/sbin/modprobe") (string-append kmod "/bin/modprobe"))))
- #t))
+ (("/sbin/modprobe") (string-append kmod "/bin/modprobe"))))))
(replace 'build
(lambda _ (invoke "make")))
(replace 'install
@@ -1292,8 +1292,8 @@ with the included @command{xfstests-check} helper.")
(string-append "INSTALL_MOD_PATH=" moddir)
"INSTALL_MOD_STRIP=1")
(install-file "contrib/bash_completion.d/zfs"
- (string-append out "/share/bash-completion/completions"))
- #t))))))
+ (string-append out
+ "/share/bash-completion/completions"))))))))
(native-inputs
`(("attr" ,attr)
("kmod" ,kmod)